Photon always gives white light, no blue light(listening mode) even after factory reset

I probably made a mistake to load the core specific code into the photon, so now the photon experienced a very wired mode, always in white light no matter i tried to put it into the listening mode or factory reset.

when i treid to put it into the factory reset, in the last step when the white light appears, I expect there would a fast white light flashing, but there is no.

how to solve it

Have you read this?
AVOID factory reset - What to do with unexpected LED behavior on a Photon

Thanks, I would update the firmware first. Could you tell where to download the latest firmware, I would like to install it locally

If you are using Particle Build (aka Web IDE), it should auto update your Photon once you flash a project.

Just be aware that this will take some time and will “reboot” three times, so be patient :wink:

Thanks, however my photon is in the ‘white light’ mode, it can’t connect to the cloud.

can I download the compiled firmware in the form of bin format without compiling them in my local environment?

Have you tried Safe Mode as suggested?

Otherwise you can find the prebuilt BINs here

Or just use CLI

npm update -g particle-cli && particle update

Hi, now I enter into the safe mode, in which the led light is breathing magenta color, then what should i do


So you should be able to OTA update.
Unless you’ve wiped your WiFi credentials, then you’ve got to set them first again (e.g. via CLI)

the led light is breathing magenta but doesn’t do anything later, no flashing megenta fast like the OTA does. so I guess I wipe out the password.
I tried - particle wifi setup,but got a error saying : Something went wrong Serial prompt timed out - Please try restarting your device.

now it might be because of the serial connection not established, but now I can’t get into the listening mode (blue led), even i pressed the mode button.

If it’s breathing magenta you are connected to the cloud. Just try flashing an app from the web ide.

You should hold the setup button for at least 3 seconds, then it will enter listening mode.

1 Like