Particle led is Solid blue

Hi everyone, my particle photon main multi-color LED between the two buttons is steady blue. I am not able to connect it to the mobile app or USB. I have tried numerous times holding both the setup and reset buttons and then releasing the reset button for making the particle breath blue (i.e; listening mode) but was unable to do so. Every time I perform the above the above step, the particle led comes down to steady blue. I even tried for factory reset but the particle led again end up breathing the same four colors.

This is not how you enter Listening Mode, but Safe or DFU Mode.
Listening Mode is engaged by first powering up the device and then press and hold SETUP alone - or when no WiFi credentials are stored but a WiFi connection attempted.

BTW, Listening Mode is not breathing blue but blinking blue.

There is no factory reset on Photon.

Yes, you are correct listening is blinking blue. Sorry for writing breathing. I tried even first powering up the device and then pressing and holding SETUP alone. But the particle does not go to listening mode. when I power up my photon, it starts blinking Red continuously and upon holding the setup button the led stops blinking Red after some time.

Can you post a video of that?

If it’s really red, something is really wrong.
Can you get into DFU Mode?