Photon 2 will not connect to WiFi when powered from VUSB

I have a very simple circuit and code that connects the Photon 2 to an external serial device and uses a function to post the data so I can access it via a simple API.

Everything works fine when the Photon 2 is powered with LiPo battery circuit.
Everything works fine when the Photon 2 is powered by USB connector.
The Photon 2 does not connect to Wifi when powered by the VUSB pin.

Any suggestions for debug?

Hi @kklinger -

Welcome to Particle forum!!

May I ask what is the power source you are using to power via VUSB pin?

Regards, Friedl.

1 Like

Thanks Friedl!

I'm just using one of several 5V (700mA) USB chargers I have at hand. I've even tried with the same charger making the connection via the USB port and then connecting to VUSB with the same results (only the USB connection works). I've tried adding a couple of caps (10uF and 0.1uF) to the VUSB-Ground to see if it might be a noise thing that the USB connection handles better than the VUSB connection but same results...seems like I'm missing something.

This is just a guess, but computers and USB hubs usually implement DPDM, current limit management. Most 2A tablet chargers do not, but there is a possibility that your 700 mA charger does. If it does implement DPDM, without the USB data lines connected it will probably default to something much lower, typically 100 mA, which would explain why you can't connect. I don't know if this is actually the cause, but it could be.

1 Like

Hi @kklinger -

My approach would be to connect a LiPo to the VUSB and GND pins directly. If the device powers up, at least you know the pin is working fine.

Regards, Friedl.

EDIT: Depending on how you plan to use the device in your circuit, you may also be able to power via VBAT pin, but i doubt that will be needed. I am leaning towards what @rickkas7 said, I would think the hiccup is with connecting a charger module to the VUSB pin.

Thanks again guys - the charger(s) I've tried only have two wires and I've verified that the 5V is making it to the VUSB pin/rail. LiPo is only 3.7V so connecting it to VUSB doesn't work - I get white flashing light which indicates reboot/low power....

Hi @kklinger -

It might, but if not enough current is supplied, the voltage might collapse when under load causing the disconnect/non-connect ??

This is strange, as far as I know the VUSB pin input should be passed through the onboard LDO and regulated down to 3V3. Let me test this quick, I will revert back in couple of minutes.

Regards, Frield.

Hi @kklinger

Apologies for the poor quality of the photo, quite late here. As you can see powering the device directly from Lipo vie VUSB and GND pins should work no problem.

1 Like

I was unable to reproduce a problem with powering by VUSB. I tried two different scenarios.

First I powered the Photon 2 by VUSB and GND connected to a bench power supply with a voltage of 5V and a current limit of 500 mA and was able to connect. I used Device OS 5.5.0 and the firmware below.

Second I ran two tests using the Otii Arc. I was limited to 4.5V but was able to successfully connect both by powering the Micro USB and by VUSB.

When powering by VUSB the maximum current was 329 mA and the average was 51.9 mA for the time until the device was breathing cyan, which is the expected behavior.

#include "Particle.h"


Serial1LogHandler logHandler(115200, LOG_LEVEL_INFO);

void setup() {

void loop() {

Thanks for this Friedl - I went back to first principles as you did with a fresh Photon 2 and no breadboard connections and can confirm I the device powers from VUSB as expected - both from LiPo and my USB charger supply. Should have tried this from the outset but I guess I got thrown off by the Particle documentation that says you can power from VUSB "with limitations". Anyway, I truely appeciate your help (and @rickkas7 below...) and will rebuild my original circuit wire-by-wire until I find the problem in the circuit or my code.

1 Like

Thanks so much for this @rickkas7 - really appreciate the truely positive confirmation of functionality (wish I had an oscilloscope...) - my bad for not going back to 1st principles as @friedl_1977 demonstrated in the first place...

1 Like

Hi @kklinger -

No problem, happy to hear the Photon is in working order :wink:

I ma not the biggest fan of breadboards, they have been the cause of many headaches for me over the years, hehe. Having said that, they do have their place.

Everyone has their own approach when it comes to trouble shooting, for me it is to simply check each section one at a time and then string them all together again :nerd_face:

Let us know should you need any further help!

Regards, Friedl.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.