Cant power via USB after VIN [SOLVED]

Got my Photons today :heart_eyes:

Started by breaking them in over the mobile app and USB power, then hooked up one of them to 3xAAA (fresh) so around 4.7V to the VIN pin, played around with it for a while and decided to connect it back to USB power for the time being, untill I get around to playing with low current modes.

But the photon wont live off USB anymore, it has seen the light of portable power and dont want to be tied down…
When I connect USB, nothing happens, I disconnected all wires to make sure there was no conflict, and the battery was disconnected before I connected USB.
But when I connect it back to battery power via VIN, it works fine.

Havent tried the same on my other two, dont want to USBrick them just to prove a point :slight_smile:
Any ideas ?

I’ll ask some “stupid” questions that might help others and so they don’t have to :wink:

Have you checked your USB cable?
Do your other Photons still work with the same cable on the same USB supply?
Can you measure the voltage on Vin and 3V3 when powered via USB? What is it?
Can you try a USB wall wart instead of USB port?

1 Like

1/2) Yes same cable works with the other photons.
3) 0.5V on VIN near 0 on 3v3
4) Just tried, and it worked, hmm…
The USB hub I am using is a powered one, so it should be able to source at least 500mA

Hm, tried a different cable anyway and that worked too.
Sorry for the disturbance :blush:

  • Does the Photon get hot?
  • If Vin works, USB should work too since they are feeding to the same power line but separated with a Diode

You can safely try the other Photons via USB but might want to leave out the AAA batteries use case till we find out what’s wrong. :smile: