Photon2 outputting 0v when powered via USB

I am trying to get my new Photon2 to output 5v on the VUSB pin.

I have the photon2 plugged in via the USB port on the board. I have tried plugging it into my computer and into a power supply in the wall. I have tried different cables. No matter what I try, I cannot read 5V on the VUSB pin.

I have successfully set up the photon2, it is connected to the cloud, and I can read 3.3v on the 3v3 pin. Not sure what else to try or if I'm missing something. Any ideas what else to try?

@pblesi and @ScruffR, I have a Photon 2 sitting on a breadboard with nothing else and I measure 5v on the Vusb pin with USB power provided.

1 Like

I can't think of a reason it wouldn't work, except for testing the wrong pin or a hardware issue. I get voltage on VUSB when powered by USB.


Hi @pblesi

Mine works just fine.

I can think of two culprits. Have you measured on the pins directly? Removing the device from the breadboard and not using jumper wires?


1 Like

Yeah, I've measured directly from the pin and still getting 0v. I guess I'll chalk it up to a bad board.

There is a Schottky diode between VUSB and the micro USB connector. It normally allows the USB port to power VUSB, however when powering the device from VUSB, it prevents voltage from flowing back into the USB port. If the diode were to fail open, USB would still work to power the Photon 2, but there would be no power out on VUSB.

1 Like

@pblesi -

As @rickkas7 said, it might that Zener. It is easy enough to check. If I am not mistaken it is the one mark in the photo.

You should be able to get ~5V (or whatever you are putting into USB) on both sides. If you only get V on either side but not the other, the diode has failed. In my experience this is not common but anything is possible.

Also no too hard to replace the diode (if indeed faulty) if you have any experience with a hot air station on soldering iron :slight_smile:

Best of luck!!


Hi everone,

Thank you for all the pointers. I tested the diode and it is working as expected. I suspect the issue is that I broke the pin when removing the headers, so that I am not getting voltage through that pin any more. Serves me right for removing the headers.

I ended up using the 3.3v out to power the NeoPixel ring I am using with the photon. This seems to work as expected for the current I am running the NeoPixel at.

1 Like