Photon 2 invalid access token

After not connecting my Photon 2 for a couple of months (I use it on the LAN), I tried a connect and publish. It never connected, blinking forever and returning connected false.
When I ran from terminal:
particle publish temp 25
I got:
Error publishing event: The access token provided is invalid.
How does one get a valid access token?
As the old saying goes: "it used to work and I didn't do nothin"

The access token expires every 90 days. You need to:

particle login

Did not know that, thank you. That resolved the token problem, now says it published but it didn't. particle list shows offline. Won't connect in program.
Tried to do a particle update, it gets to about 85% and times out with Update failed, pink light on. Works on LAN, so I will assume that the connection stuff is probably broken.
Thanks for your help.
oops, I lied. Now, nothing works.

Finally got it to finish the update by installing Chrome and using that. Updated the compile target and got local network working. Still shows offline and particle identify says undefined and unable to determine system firmware version. It is working to local network, I guess I will just live with that. Not much else to do.

Hi, maybe there is some firmware running on the device that is impacting its ability to connect to the cloud?
If so, you can try:

to get it back to a known state.

Thank you. I had done that to get it back to working on the LAN. Did it again just now, no change.

OK, the short version:
Everything I have tried gives the same result, device is offline and identify says unknown. I can still do stuff on the LAN.
Update from the CLI fails and from Chrome says it is working but it really isn't. Out of desperation, I ran doctor. That times out (after resetting WiFi) and says to come here and ask for help. That hasn't worked either.
The bad news: The boss says that Photon 2 (at least this particular one) is a dud and not ready for prime time. Stop wasting time with it.
The good news: He said I can have it and use it for a temperature gauge.
Thank you to those who tried to help me. I recognize that I am in the slow group.

Hi Lou,

Do you mind DMing me your device ID and we can take a look on Particle's side what issues there may be.


Sorry, dummy here. How do I DM you?
oops, I think I figured it out.