Particle setup is stupid

I purchased a couple of boron boards a few months ago. They arrived and sat for a while. I finally pulled them out of the box and tried programming

I followed all the directions for installing the IDE and compiling software and I tried to load a led-blink example and it flashed ok. But then the LED didn’t blink. Nothing I tried worked. I did have to work through some linux issues, like they don’t tell you how to set up udev rules, but I know enough not to expect to not have to allow access to devices.

So, I read everything I could to try to make this work and the board just kept flashing that stupid green light.

I finally came across the docs that told me about the green light. It told me all sorts of things, but mostly it said to just use the app. I tried to register my board with the app, but it couldn’t register because it only flashed the stupid green light. No help provided from there.

Finally after too many hours of googling and scouring the docs did I come across a way to reset the board using the particle command line app. I ran the single command line script and I was finally able to flash my original firmware to blink the D7 led.

Why doesn’t the particle standard IDE allow me to flash my simple firmware app before registering the SIM? I don’t know, but I’m sure lots of people have given up long before I did. I wish I could get all my time back.

I really like the particle ecosystem, and the ability to quickly and easily deploy apps that use our cell network with simple data-driven embedded systems, but I really don’t like how difficult the system is to get something simple working. I’m hopeful the rest of my idea doesn’t take more work to do.

I hope others have less trouble and that there’s not more speedbumps to accessing the use of the particle ecosystem.

mostly for future users, there is this web tool that one can use in Chrome and Edge:



Thanks for sharing your experience. I am glad you like the ecosystem as a whole and really appreciate hearing about your experience with setup. It is a known issue and one that we are working to fix. The tool @gusgonnet linked is currently in beta but after testing concludes we will release it and it will replace the current setup experience.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.