Particle photon capability for touch/ capacitance analog read?

i want to know if touch sensing capability is there for photon? I want to get capacitance values from user for my application project

Have a look at the lib mentioned there
Photon and Core firmware updates cause code malfunction using interrputs (for a touch project)


Its not working properly, after attaching library to my application its giving errors.

Yes there are problems with the lib - hence my comments in the thread to get arround them.
If you get any other errors it would help to know what they are.

While this is more of an alternative than an answer to your question: i use mpr121 breakout modules for touch and proximity sensing and they are pretty cheap (eg 3 € from china). They have up to 12 independent touch points and work perfect with my photons. Might be worth to Check out for you.

Thank you

I am trying to compile code in Particle dev. I got this error, Objbase.h no such file or directory found. How to go about this?

This is the error i get. How should i go about it?

First you should have a dedicated directory for your project which only contains one .INO file and all the required .H/.CPP files.
Your screenshot suggests that you have a rather crowded directory for your project. This won’t build even if you had the referenced objbase.h present.

where should i build it? Can i just buld it in my desktop directory? i was building in default directory and i was getting this error

Just create a dedicated directory anywhere you like, but I usually use a short path with no blanks or special letters in it - just to be safe.

e.g. C:\Particle\Projects\Dev\MyProject or if not in C:\ you can put it in your USERS\Documents\...

i saved the way you asked me to, i still get the same error . :frowning:

Could you supply another screenshot with your new project structure?

And as I see on your previous scteenshot, you need to name your main project file capacimeter.INO and save it.
The screenshot suggests you’ve called it capacimeter and have unsaved changes (blue dot on tab).

What is this i2c_t3.h. I can’t see such a file in your path and I don’t know it as a Particle file either.
What error do you get when you click on the red (!) One error at the bottom line?

1 Like

i get same objbase.j no such file or directory

@Vindhya, can you post the full code or the link to the code you are using. I believe there are “legacy” arduino items that are interfering with the compile.

i get same error if i try to run any simple code.

When you open your project, are you just opening the file or the folder.
I’ve stopped using “Open File …” as it sometimes caused problems that didn’t occure with “Open Folder …”

i am adding my project folder instead opening my file