Particle Mesh Functionality without WiFi Connection

argon
xenon
Tags: #<Tag:0x00007f0392817648> #<Tag:0x00007f03928173c8>

#1

Hi all,
I am working on mesh communications between an argon and a xenon. When in range of my WiFi network, my mesh communication works as I expect.

When I step outside of my WiFi coverage zone, the argon tries to continuously connect to the network out of range. During this time, my argon mesh receiver seems to miss a lot of messages.

I’ve tried disabling the WiFi altogether by changing System Mode to Manual and turn Mesh.on() afterwards, but it seems to break my code entirely.

Can an Argon and a Xenon be set up to only work as a Mesh network, or does it need internet access to function properly?

Thanks
-Clay


#2

Without knowing much about your code there is little helpful information we can distill from that sentence - but I’d first try SYSTEM_MODE(SEMI_AUTOMATIC) before going fully MANUAL.

Have you tried SYSTEM_THREAD(ENABLED)?
Are you checking whether the WiFi/cloud connection is active before performing any tasks that would require it to be?

Yes, when the application is setup correctly.


#3

To add to what @ScruffR said, the same applies to your Xenons as they default to SYSTEM_MODE(AUTOMATIC) unless specified otherwise and will wait on a Cloud connection.

Note that when not connected to the Particle Cloud, you will not be able to OTA to any of your mesh devices.


#4

Just remembered that there is a bug with SYSTEM_MODE(MANUAL) and (SEMI_AUTOMATIC) on mesh devices.

Device Issue #2 – SYSTEM_MODE(MANUAL) and SEMI_AUTOMATIC not working properly