"particle library upload” fails


#1

Hello. I’m unable to upload to the library per the instructions. I’ve tried:

particle library upload

from inside the library directory, which gives:

This library could not be imported. Try another library or try this one again later.

I’ve also tried:

particle library upload InfluxDB

from the directory above, per this thread. That gives:

Command parameters 'InfluxDB' are not expected here.

There’s no information to advise what’s wrong - code error, system failure, etc.

Can anyone advise? Many thanks.

(Code on GitHub here)


Thingspeak Library not working with Mesh
#2

What version CLI are you using?
You are executing particle library upload from the directory where the library.properties file lives?


#3

Hello.

particle CLI version 1.27.0.

Per my post, I’ve tried two ways:

  1. from the directory where library.properies lives
  2. from the directory above

#4

Particle has now prompted me to upgrade to 1.27.1

particle library upload now yields "This library could not be imported. Try another library or try this one again later.” for particle 1.27.1


#5

The silly thing is there currently is no way to delete uploaded libraries, otherwise I would try to upload your library to pinpoint the issue.
But that’s no option otherwise the library name would be taken and you couldn’t upload it anymore.

If I take your sources and upload with another name it works for me - no clue why.

Maybe @rickkas7 could have a look and maybe loop in some engineer assigned to the Library Manager.


#6

Thanks for looking into this for me - standing by


#7

Should I assume that this advertised feature is broken?


#8

@richlyon, if you already have an uploaded library, you need to change the version number in the properties file for the update to replace the existing one.


#9

As I said

So it’s not broken but there must be some other issue - and @peekay123’s suggestion would be one possible cause, although I casually dismissed that thought as there was no sign of a previous upload with which yours could have collided, not thinking that there might be a previous private (and since invisible) upload with a higher version number than yours and the system might just check version before ownership.
Since if you try to upload a library which was already uploaded by someone else you’d get a “You are not the owner” message (normally, but with a version conflict the check could bail out before actually realising the discrepancy in ownership).


#10

OK - thanks. Appending my initials to the name property fixed it. Seems to be a silent fail on a name collision.


#11

Silent/misleading fails are bad and hence I’ve opened an issue about this


#12

+1 for changing the name of the library