Particle flash --factory


#1

I am trying to flash on a Electron a very simple code for backup but I got this error:

Flash device failed: no files included

I downloaded the compiled *.bin file from the online Particle Builder.

What’s wrong?


#2

How exactly do you try to flash the binary?


#3

Put the electron in DFU mode (blinking yellow) conneted to the USB and I run the command

particle flash --factory emergency.bin

where emergency.bin is my custom code compiled


#4

I don’t think you want to use

—factory

here,

Try

particle flash --serial emergency.bin


#5

Why? I want to save the code into the backup memory area not the main.


#6

Ahh, OK, my bad. I wasn’t getting that, my experience all goes to the flash – serial.
Oops!
J


#7

The actual command to flash a binary to the factory reset space would be

particle flash --usb emergency.bin --factory

But as we found out (when I tried it before posting here) that’s currently causing some problem.
An issue report has been raised.


#8

Oh :sweat:

Ok for the moment I will survive using the SAFE MODE, I had some doubt using it with third party SIM but it seems it works…


#9

Can you elaborate in what way you’d facilitate the factory default firmware?
Do you anticipate your device needing to be “factory reset” by a user/customer?


#10

Yes kind of, but I was trying the way of “facotry reset” just because I did’t realize that SAFE MODE can accomplish the job as well…