[RESOLVED] Electron USB & serial flash not functioning

Hello all,

I am having some issues flashing a simple app to my electron (the goal is to read temperature using a sensor and just send that info to my computer/smart phone/etc.)
When I flash to usb using the following lines of code in the Node command window I get the error message shown below:

particle flash --usb firmware.bin
Found DFU device 2b04:d00a
Error writing firmware…file does not exist and no known app found.

When I flash via serial I get a similar error message:

particle flash --serial firmware.bin
! PROTIP: Hold the SETUP button on your device until it blinks blue!
? Press ENTER when your device is blinking BLUE
! serial:
Error writing firmware…file does not exist and no known app found.
undefined

I’m not sure what exactly is going wrong because I have reset and restarted my device a few times, it is breathing cyan, and has previously allowed an app to be downloaded directly via USB in the Particle Build (no longer an option for some reason). Does the firmware.bin need to be in a particular folder for my device to locate it or something?
If anyone has any suggestions for solutions or courses of action that would be greatly appreciated.

I’m not sure what you mean by that.
You should not execute these from within Node but from your OS’s terminal/console (for Windows cmd or powershell) and you need to execute the command from the location where your firmware.bin actually lives.
Otherwise you’d rather run particle flash --usb /actual/path/of/your/firmware.bin
(and of course, your binary must actually be called firmware.bin otherwise replace the name with the one of your actual file)

With --usb your device needs to be blinking yellow and for --serial blinking blue, none of them will work while breathing cyan.

1 Like

First off, thank you for your prompt response. I mis-spoke on both accounts. I am in my OS’s terminal when I do all of this and I changed the mode of my electron depending on whether it is serial or USB.
I frankly wasn’t aware of the path that I needed to use, as this is sort of out of my realm of expertise:

That worked for me though so thank you!

3 Likes