Particle Dev objbase.h no such file Cannot compile

Continuing the discussion from Objbase.h no such file or directory:

I downloaded Particle Dev and copied over my file from the web site. It works just fine there with my photon. But, I am not able to complete the compile or download with this error message. I followed the suggestions to create a project file and saving but not success. I have selected my device but I’m not getting that far in the process

First time user! Suggestions?

Thanks

Is this your screenshot, if not provide one of your own setup.

If you haven’t already tried/followed the suggestions in the other thread, try them.

I tried all your earlier suggestions on the other thread regarding file locations.

I did look at Git Hub and see that it requires Visual Studio and other packages. I was wondering why I did not see any color coding on my program. :frowning:

I really wanted to use the tools but committing to other packages as well seems to be the order.

Suggestions

One thing I see there is that your files seem to have no file extensions .INO, .CPP, .H - this might also be the cause for the lack of color coding.
Another thing to avoid is blanks in the path - rather use PhotonProjects instead of Photon projects.
Also - even more - absolutely no blanks in file names!

And finally use File - Open Folder ... to select only your actual project folder and don’t try to select parent folder (as in your screenshot C:\User\text\Documents)


BTW: I can trigger the same error message when I have the Particle Dev program folder (e.g. app-1.0.19) inside my selected project folder. Since you and the OP of the other thread also have this, it’s most likely the cause for this error message in particular.

Many thanks for your help. Yes, I changed the folder locations and names and am now being asked for libraries. Compiling is not an issue now. Kind of stupid mistakes. Thanks for spotting them.

1 Like