Particle command line broke

So… i tried to install the standalone “po” so I wouldn’t have to use the web for development… It didn’t work and now my particle-cli tells me

“Please reinstall the CLI again using npm install -g particle-cli”. When I run it, I get no errors, but it still doesn’t allow me to continue… I get the error everytime.

Oh, yeah, I’m installing everything on a MAC

The easiest way to fix this is:

Remove any old installation. If you get a command not found error, just go to the next step.

sudo npm uninstall -g particle-cli

Then install using the Particle CLI installer:

bash <( curl -sL https://particle.io/install-cli )

If you still get an error running the particle command, do:

which particle

If it returns one in /usr/local/bin/particle, remove it:

sudo rm /usr/local/bin/particle

There are additional instructions here if necessary:

https://docs.particle.io/guide/tools-and-features/cli/

I tried “bash <( curl -sL https://particle.io/install-cli )” - it came back immediately without processing anythng. SO… I copied the https into my browser and got something else so I entered “bash <(curl -sL https://raw.githubusercontent.com/spark/particle-cli-wrapper/master/installer/unix/install-cli)” it’s working on that now…

1 Like

This should also work:

Edit: If the problem is already resolved you won’t need this.