CLI gone awry for no apparent reason

My CLI has seeming gone awry and I don’t recall doing anything that would fuss it up. When I do something as simple as a particle list I get the following:

I’ve tried reinstalling the CLI with the following command: sudo npm install -g particle-cli but without help.


(I’m running Mac 10.13.3 and have not had any CLI issues for the past year)

[update] I tried doing a reinstall with sudo and got the following:

1 Like

This usually works for me:

sudo npm uninstall -g --unsafe-perm particle-cli
sudo npm install -g --unsafe-perm particle-cli
1 Like

You DA Man!!!

So…the only remaining question is…why did this happen?

Regardless, I very much appreciate your help!

1 Like

happened to me proceeding my enabling my github account for two factor authentication.

unintended consequences!

1 Like

This happens to me a lot. You installed something else that needed and installed a different version of npm or node and that messed up your Particle install.

1 Like