Particle CLI Installer (Windows)


#25

i went to the website of norton to investigate and found this 7 year old write up .
https://community.norton.com/en/forums/clarification-wsreputation1-detection
it seems like a bogus explanation and very poor way to treat companies doing legitimate business.


#26

It should be fixed now. Norton accepted the whitelisting so the Windows CLI installer should not be flagged as a virus now.


#27

FYI: It looks like this problem is back …


#28

Hi. I am pulling my hair out for 3 days trying to install Particle CLI on Windows 7 on 3 different pcs. My internet connection get cutoff while trying to install the cli. Has anyone encountered this problem?
I also tried downloading by tethering my mobile and my wifes mobile via hotspot.
All instances executable hangs, internet gets cut off. Need to restart router again each time to try all over again.
Called my service provider, they seem hopeless! They said since you can download from other secure sources it obviously isn’t our fault!


#29

@eLumaLite are you having problems downloading the CLI installer or having issues running it?


#30

Running it.


#31

I downloaded the setup file but hangs while trying to download and install components


#32

Can you show where it hangs (screenshot)?


#33

Sometimes installing the CLI on a windows machine takes 20+ mins to complete as it downloads and then installs everything. It could take an hour if your internet connection is slow based on my experiences.


#34


Took 1 hour to get to here…
Again I lost connection. 50Mbit download speed from MTN in Cyprus.


#35

Leaving the setup open and resetting router it got to finalize but with errors.1423


#36

What does particle do, when typed in the command line?


#37

I ran 10setup and got this 10mins later

So I tried this


#39

That seems to be alright :slight_smile:


#40

Oh man…head ache just vanished instantly! Thank you :slight_smile:


#41

All seems good I believe with the installation. Firmware 0.7.0 been updated to Photon. Visible in my devices.
Now I have been trying to upload my projects OTA. Flash starts but noticed the magenta light is on for 5 secs then off for 5 secs. This attempt lasts about a minute then restarts and connects to cloud. Not the typical the flashing sequencing I had before with any of my other Photons and projects. I dont think it flashes successfully.
Tried various Blynk projects with Photon, but doesnt seem to connect in Blynk.


#42

If it needs to update the system firmware as well, the process can take a bit longer. You can take a look at the event stream in the console to get an idea of what’s going on.
Also, if you’re flashing things “just to see if it works”, please do try something simple/known working like Tinker or blink an LED. That rules out coding issues.


#43

Thank you Moors7.
Blynk DNS issues was the problem. All fixed now!