Particle CLI Installer (Windows)


That output looks rather normal to me :wink:
What does

particle --version

give you?

Maybe you want to try npm uninstall -g particle-cli and then try to install again.


Particle --version

npm uninstall -g particle-cli gives

unbuild particle-cli@1.17.0

If I try install I get exactly the same as I have shared above!


That looks as if you have (had) got two instances of CLI and possibly also of node/npm installed.

When you did particle --version the 1.16.0 instance was found first but the npm instance you were executing the uninstall command with obviously rather got 1.17.0 first to remove.

What happens when you execute the uninstall twice?
Can you locate another particle-cli folder after you uninstalled?
Does particle --version still work after you unbuilt 1.17.0?

You can look for particle-cli in





Running uninstall twice takes away the 1.17.0 version only and leaves the 1.16.0 version.

I can see copies in appdata\Local and appdata\Roaming.

Can I just delete these files and start again?

Update: I removed the local version of the files and 1.17.0 was exposed and working! Thanks for the tip about the second version.


This is an FYI:

Norton Internet Security deletes ParticleCLIsetup from my Windows computer when I download it.


Damn paranoid Norton antivirus…


I submitted this as a false positive detection but there’s no indication of how long correction would take.


i went to the website of norton to investigate and found this 7 year old write up .
it seems like a bogus explanation and very poor way to treat companies doing legitimate business.


It should be fixed now. Norton accepted the whitelisting so the Windows CLI installer should not be flagged as a virus now.


FYI: It looks like this problem is back …


Hi. I am pulling my hair out for 3 days trying to install Particle CLI on Windows 7 on 3 different pcs. My internet connection get cutoff while trying to install the cli. Has anyone encountered this problem?
I also tried downloading by tethering my mobile and my wifes mobile via hotspot.
All instances executable hangs, internet gets cut off. Need to restart router again each time to try all over again.
Called my service provider, they seem hopeless! They said since you can download from other secure sources it obviously isn’t our fault!


@eLumaLite are you having problems downloading the CLI installer or having issues running it?


Running it.


I downloaded the setup file but hangs while trying to download and install components


Can you show where it hangs (screenshot)?


Sometimes installing the CLI on a windows machine takes 20+ mins to complete as it downloads and then installs everything. It could take an hour if your internet connection is slow based on my experiences.


Took 1 hour to get to here…
Again I lost connection. 50Mbit download speed from MTN in Cyprus.


Leaving the setup open and resetting router it got to finalize but with errors.1423


What does particle do, when typed in the command line?


I ran 10setup and got this 10mins later

So I tried this