Particle blinking red and not detected via usb

I have had my photon particle for 2 months and this morning I couldn’t connect it to my phone so I unclaimed it and then try to claim it. Everything went well until the verifying device step. My photon is now blinking cyan with short blink of orange and green. I tried using dft ult to fix it but so far no luck. Thank you for your help. Also I tried particle keys new but it gave me this error.

@khoitd1997 Sorry to here your having an issue, did you by chance install openssl?

If not, try downloading and installing it and running the keys command again.

The install links are a bit tricky to find so I have linked them for your below, pick the one that best matches your install (32 or 64bit)

Open SSL 32 bit:
Open SSL 64 bit:

Let me know if you still are having issues.

Before you do too much to the device, sometimes the device needs some attempts to get over this “orange burst” state (up to five times should be enough tho’), especially if you have a noisy WiFi setting.

Maybe you could shoot a short video ot the attempts and post here

But having OpenSSL in place in order to have CLI/dfu-util work properly is always a good thing too :wink:

Thanks for your help, I tried installing SSL and it works, I got a new key and try to flash it in DFU mode however, the LED still blinks like this.

@khoitd1997 Glad to see that ssl helped and the video helps as well. It looks like you still have an issue with the keys on your photon.

To fix it you can do the following (please note i have provided instructions for flashing keys if it has never been connected to the cloud, and if you have had it connected to the cloud previously. chose the one that best matches your situation). Also please note you need to have the dfu-util installed on your machine. if you do not have it already, you can go to [Particle Official] Windows 10 Full CLI and DFU Setup and start from step 3.

Flashing keys on a device that has been connected to the cloud before:

  1. Place your photon into DFU mode

  2. Download the server public key from

  3. from command prompt run the following command
    dfu-util -d 2b04:d006 -a 1 -s 2082 -D cloud_public.der

Flashing keys on a device that has not yet been connected to the cloud:
1.Using particle, first generate a new key:
particle keys new

2.Then put the device in DFU mode and flash this new key
dfu-util -d 2b04:d006 -a 1 -s 34 -D device.der

  1. Then reboot the device and it should connect to the cloud.

For future reference you can find how to fix this issue here: Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]

Let me know if you still need help or if this solves your problem.

1 Like

Thanks for your help, the link that you gave me seems to be dead, but I used the link to the topic you gave me and I did as instructed but photon still flashes the same way. Oh and every time I finished flashing the new key, do I hit reset to reboot the photon or do I just pull the plug out?


sorry about that, did you try putting your device in DFU mode and running the following command:

particle keys doctor your_device_id

Note: replace your_device_id with the device id burned into the device (same id you can get with particle serial identify) IF it fails to send that new key to the cloud (sadly this can happen at times) you will have to make sure to run particle keys send as well

The command above should refresh the cloud and your device with a new set of keys and hopefully also solve your issue.

Good question, You can just hit the reset key and it will do a restart of the photon

Both would do the same thing, for resetting - pulling the plug out won’t restart the device tho’ :wink: (replug too :stuck_out_tongue_winking_eye: only kidding ;-))

Hey, sorry for resurrecting a dead post, I just want to thank you guys so much for helping. My device worked again, I was going to order a new one but this saves me a lot of troubles.

1 Like