Particle(Atom) dev worked yesterday, but not today

Simple blink.ino works on Web IDE
Also worked on Particle IDE yesterday
Today when I try to compile, I get this:

helpful info as follows:

[Enter steps to reproduce below:]

Atom Version: 1.5.1
System: Microsoft Windows 7 Home Premium
Thrown From: spark-dev package, v0.0.32

Stack Trace

Uncaught TypeError: Cannot read property ‘replace’ of undefined

At C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\views\compile-errors-view.js:57

TypeError: Cannot read property 'replace' of undefined
    at CompileErrorsView.module.exports.CompileErrorsView.fixInoFile (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\views\compile-errors-view.js:57:22)
    at Object.content (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\views\compile-errors-view.js:87:21)
    at Builder.tag (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\atom-space-pen-views\node_modules\space-pen\lib\space-pen.js:281:19)
    at Function.View.(anonymous function) [as li] (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\atom-space-pen-views\node_modules\space-pen\lib\space-pen.js:83:49)
    at Function.<anonymous> (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\views\compile-errors-view.js:78:21)
    at Function.View.buildHtml (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\atom-space-pen-views\node_modules\space-pen\lib\space-pen.js:123:10)
    at Function.View.render (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\atom-space-pen-views\node_modules\space-pen\lib\space-pen.js:129:19)
    at exports.$$ (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\atom-space-pen-views\node_modules\space-pen\lib\space-pen.js:627:24)
    at CompileErrorsView.module.exports.CompileErrorsView.viewForItem (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\views\compile-errors-view.js:77:14)
    at CompileErrorsView.module.exports.SelectListView.populateList (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\atom-space-pen-views\lib\select-list-view.js:206:29)
    at CompileErrorsView.module.exports.SelectListView.setItems (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\atom-space-pen-views\lib\select-list-view.js:167:12)
    at CompileErrorsView.module.exports.CompileErrorsView.show (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\views\compile-errors-view.js:67:14)
    at CompileErrorsView.show (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\views\compile-errors-view.js:3:61)
    at Object.module.exports.showCompileErrors (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\spark-dev.js:820:37)
    at atom-workspace.disposables.add.atom.commands.add.spark-dev:show-compile-errors (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\spark-dev.js:117:26)
    at CommandRegistry.module.exports.CommandRegistry.handleCommandEvent (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\src\command-registry.js:260:29)
    at CommandRegistry.handleCommandEvent (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\src\command-registry.js:3:61)
    at CommandRegistry.module.exports.CommandRegistry.dispatch (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\src\command-registry.js:160:19)
    at C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\spark-dev.js:740:29
    at Object.module.exports.projectRequired (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\spark-dev.js:382:14)
    at C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\spark-dev.js:679:24
    at Object.module.exports.loginRequired (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\spark-dev.js:364:14)
    at Object.module.exports.compileCloud (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\spark-dev.js:677:19)
    at atom-workspace.disposables.add.atom.commands.add.spark-dev:compile-cloud (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\spark-dev\lib\spark-dev.js:132:26)
    at CommandRegistry.module.exports.CommandRegistry.handleCommandEvent (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\src\command-registry.js:260:29)
    at CommandRegistry.handleCommandEvent (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\src\command-registry.js:3:61)
    at CommandRegistry.module.exports.CommandRegistry.dispatch (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\src\command-registry.js:160:19)
    at space-pen-button.<anonymous> (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\tool-bar\lib\tool-bar-button-view.js:42:36)
    at space-pen-button.jQuery.event.dispatch (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\jquery\dist\jquery.js:4435:9)
    at space-pen-button.elemData.handle (C:\Users\Butch\AppData\Local\particle\app-1.5.1\resources\app.asar\node_modules\jquery\dist\jquery.js:4121:28)

Commands

     -6:39.5.0 spark-dev:compile-cloud (atom-text-editor.editor.is-focused)
     -6:39.5.0 spark-dev:update-compile-status (atom-workspace.workspace.scrollbars-visible-always.theme-monokai.theme-one-dark-ui)
     -6:39.5.0 spark-dev:show-compile-errors (atom-workspace.workspace.scrollbars-visible-always.theme-monokai.theme-one-dark-ui)
     -0:23.5.0 core:paste (atom-text-editor.editor.is-focused)
     -0:16.5.0 spark-dev:compile-cloud (atom-text-editor.editor)
     -0:16.4.0 spark-dev:update-compile-status (atom-workspace.workspace.scrollbars-visible-always.theme-monokai.theme-one-dark-ui)
     -0:16.4.0 spark-dev:show-compile-errors (atom-workspace.workspace.scrollbars-visible-always.theme-monokai.theme-one-dark-ui)

Config

{
  "core": {
    "themes": [
      "one-dark-ui",
      "monokai"
    ]
  }
}

Installed Packages

# User
No installed packages

# Dev
No dev packages

end of helpful info

What to do now?

Sing to the Pink Floyd tune in “The Wall” album…

“Is any body out there?” … :open_mouth:

Hi @butchalline sorry for not responding earlier. We fixed this in latest version of Particle Dev package but haven’t updated the app yet. You could try using the CLI to compile your project or use Atom and “bleeding edge” version of Particle Dev.

Thank you Suda
How will I know when the Dev IDE app is released?

We’ll try to release it as soon as possible (this week or the next).

Thank you.

In general, where would one find out about important releases?

Particle Dev App should update automatically, but we also publish change logs in https://community.particle.io/c/particle-updates category and the latest version is always available on GitHub’s releases page: https://github.com/spark/particle-dev-app/releases

Getting same error on 16 May and not updating automatically per below:

Is ver. 1.7.3 as shown below the “latest version”?

Help! I am confused…