P1 SoftAP prompts for password when reconnecting to WiFi

We are using P1s firmware ranging from 0.5.1 to 0.6.2. The first time the device is connected to our corporate network the SoftAP claiming process works fine.

If we reset the device by holding the setup button for 10 seconds, the claiming process no longer works. iOS will prompt for a password every time we try to connect the the SoftAP.

If we wait a day or so, it will work again, but just once.

This issue is reproducible 100% of the time on every device we try.

I added a comment to the following bug that had been closed. But we are still having the issue:

Hello,

Let me ping someone that might be able to help, @tylercpeacock are you able to assist?

Kyle

What password is it prompting? The WiFi SSID password?

When you say the claiming process no longer works, did you try power cycling the Photon and connect using the mobile app again?

What is the configuration for your corporate network? WPA2?

1 Like

@pnoyes, are you refering to the SoftAP process outlined here
https://docs.particle.io/reference/firmware/photon/#softap-http-pages

If so this hasn’t got anything to do with claiming the devices in the “Particle meaning” of the term.
Claiming a device usually refers to the action to tie a particular device to your account.
SoftAP is usually used for providing WiFi credentials for a device to lock onto your network.

If you have extended the SoftAP code in a way to actually claim the device (in the local meaning of the term) you might have to provide some more background on your particular code.


(I see @kennethlimcp has beaten me to this :wink: )

Hello,

For all of this I am referring to the SoftAP process for providing WiFi credentials for the device. Sorry, I have been using those terms interchangeably.

I am attempting to use an iPhone to connect to the P1 by going to settings and choosing the ‘Photo-XXXX’ SSID. At this point it will bring up a dialog on the Phone that says “Enter the password for “Photo-XXXX”.”

It is my understanding that it should never prompt for a WiFi password to connect to the SoftAP.

Power cycling the P1 has no effect.

I have not extended the code in any way, I am simply trying to test the default process for configuring the WiFi credentials using the iPhone.

This happens only at our corporate office where we use Meraki access points. If I take the device home where I am different access point then it works fine. It is bizarre because just being in the presence of the Meraki’s will trigger this behavior after the initial configuration.

This sounds more like an iPhone issue than a Photon issue, since the Photon’s SoftAP is always an open network without password. I’ve never seen this behaviour on any of my devcies.

This happens with multiple phones. I also can’t get my Mac to connect to it.

A while back others have had this problem and I it seems to still be unresolved:

I figured it out.

The Air Marshal feature of the Meraki units spoofs the Phone SoftAP’s SSIDS

1 Like