Nothing compiles (Oak)

Everything i attempt to compile gives this error message:

“Error: Could not compile. Please review your code.”

None of the examples compile.

My code looks like this:

void setup() {  
void loop() {  

and still will not compile. That would work fine in arduino IDE.

Please, what have i missed? and why do none of the examples compile out of the box?

Can you perform a refresh? Just did a compile and things worked fine for me. I presume you are using the Web IDE?

Yes, the web IDE.
by refresh, do you mean the browser page?

I’ve tried on multiple laptops and my desktop machine… all the same result. I’ve tried firefox and chrome. All the same result.

Can you make sure there’s a device selected :star: in the device tab?

how to a select one? I can see the list. Clicking on one displays it’s device id. Can’t see how to select it.

Ah… What device is that? Photon/Duo/Electron/Core?

Can you hit the Settings button, then do a Clear Cache. If it still doesn’t work, login the Web IDE using incognito mode and check if the device is properly identified.

This is an “Oak” board.

Thanks for your help. trying incognito.

Same result after incognito and after clear cache.

Let me check with the :particle: team and get back to you.

Ping @Dave @corey

1 Like

Hi All,

Just double-checked, the build farm is working fine, but as far as I know Oak hasn’t setup a build environment yet for the build farm. I’m checking with Erik and the team and I’ll work on getting that folded in as soon as I can.



For the time being it looks as if you have to resort to the Arduino IDE - that works fine with the Oak.

I have had the same experience as you, albeit in the opposite order, i.e., I first did my coding in the Arduino IDE and then tried the web one. No luck there, as you are aware.

Still - today I managed to publish a Particle variable to Particle cloud and access it through the browser. Felt good! :smile: Next step is to hook up a sensor to the Oak and go data collecting…

1 Like

Hey @Dave, is there any more news on this… it’s now a few more months later (ok, maybe more than a few! :wink: ) and whilst there is an entry for a 1.0.5 fw (it might have been 1.0.5 PR at first?) on the Particle Build IDE, it a first was only good for bricking Oaks, and now seems to simply refuse to compile? Just wondering if there was any more news on progress, etc?

Hi @pfeerick,

Good question! I believe @suda has taken this project over, I’ll reach out to him and see if he can post here about how things are going. :slight_smile:

edit: I just discovered he’s on vacation until next week, so hopefully he’ll post here then. Sorry about the wait!


hahaha… talk about timing! Thanks for chasing that up… as you can tell there isn’t any particular hurry, just wanting to know what the situation is… so an update in week or so will be just fine… I wouldn’t be like this guy just yet… poor fella! :wink:

1 Like

Haha, thanks :slight_smile:

Sorry for not being able to respond earlier! It looks like the whole new compiler had some issues due to Redis being out of memory. This should be fixed now and we’ll investigate the issue so it doesn’t happen again.

1 Like

Thanks for that @suda. Now that I have your ear… wait for it… is it actually supposed to work yet? As it now compiles (thanks!), but like the behaviour I saw last time I tried it, it is only good at bricking Oaks in one easy click! :open_mouth:

The code uploads, but when the Oak boots, it’s dead as a doornail. And this is all you get when you connect to the serial console (with the last two lines repeating endlessly. Up to the Oakboot v1 line everything appears normal, but after that… it appears to have all terribly, terribly wrong. Just a good thing I have a firmware restore system in place so it’s a 30 second fix followed by avoidance of Particle Build for another three months! :laughing:

 ets Jan  8 2013,rst cause:2, boot mode:(3,3)

load 0x40100000, len 3632, room 16 
tail 0
chksum 0xc0
load 0x3ffe8000, len 352, room 8 
tail 8
chksum 0x82
csum 0x82

OakBoot v1 - N,BP,4

Fatal exception (3): 
epc1=0x4000df64, epc2=0x00000000, epc3=0x00000000, excvaddr=0x40201010, depc=0x00000000

@suda Cat got your tongue? :stuck_out_tongue: Or did I just send you running for cover? :laughing:

Oh sorry Peter, I passed this to Oak team right after you posted it and waiting for a fix now :blush:


lol…Thanks for that. I’ll go hide back in my box now and wait patiently!! :laughing: