Not writing or ARGON or Serial not working?

Hello everyone, I got my self an Argon board. My end goal is to create a working mesh network with this device. But… I’m stuck at the easiest task. What I have done is, install Visual Studio Code. Later I also installed stuff via the Particle Installer for windows. Next is I went into DFU mode, the led was yellow. I updated to 1.5.0. Next thing I tried is flashing it, it didn’t work. I tried going to DFU mode and uploading the code this worked but, I didn’t get anything in my Serial. Next thing I tried was registering the device and uploaded it via the Web IDE, this give me an OK for flashing but, serial was still empty. Listed below is some small code and the error I get from vs-code.

Code:

/*
 * Project bluetooth-mesh
 * Description:
 * Author:
 * Date:
 */

int counter = 0;

void setup() {
    Serial.begin(9600);
}

void loop() {
    Serial.printlnf("testing %d", ++counter);
    delay(1000);
}

Error:

I think the error has to do with some Serial port not working or something. I had the same issue with an ESP32 board. I couldn’t upload on it via vs-code unless I hold down the boot button while connecting to serial port. It would upload good but, reading from it’s serial port didn’t show anything (Arduino IDE serial port and Putty serial port did show text on serial monitor).