Not able to update firmware, BSOD on USB power

I have a Photon that was working fine on an experiment as of about a month ago. The battery pack drained and when I tried to boot it up again, the firmware seems to be corrupted. I am getting a random sequence of cyan blinks followed by a single red blink at irregular intervals. I can put it into listening mode and find it with the app, but in the setup sequence it fails after connecting to the WiFi.

Seems like a straightforward fix, upgrade the firmware with the CLI application (running Windows 7). HOWEVER, when I plug in using a USB cable, I get a blue screen of death system failure (flagged “BAD_POOL_CALLER”). My system will continue having this crash on restart until I disconnect the USB cable.

Anyone ever had this happen or have suggestions for how I can refresh the firmware given my WiFi and USB issues?

When you say “disconnect the USB cable”, do you mean from the Photon or from your computer?


I see this all the time when I pull the USB plug from my laptop while I'm reading data from the Photon or Electrons Serial Port using Terra Term software on Windows 10.

This BSOD also happened when using the Particle Doctor command via the latest CLI as it asks you to put the device into DFU mode a few times during the update process. When I hit the reset button I got the BSOD at least one the other day while resetting a Photon.

I also see the same “BAD_POOL_CALLER” error message.

I'm running Windows 10 + Bootcamp on a 2017 MacBook Pro.

I only tried unplugging it from the computer’s USB port, though I would assume unplugging from the Photon port would do the same.

Basically if I leave the Photon connected via USB to the computer as the computer is restarting, it will continue to crash during the computer’s boot sequence.

Additional info:

  • I can connect to the computer without crashing by entering DFU mode on the Photon BEFORE I connect the USB cable. I can then run the dfu-util, but when it finishes and goes back into normal mode the computer crashes again.

  • I do not seem to be able to enter Safe Mode on the Photon.

  • When I put it into Listening Mode and try setting up via the app, it fails on the “Disconnecting from softAP” step.

Is the device dead or is there any way I can factory reset the firmware?

Yes, same BSOD either way.

That does not happen to me. It will reboot just fine without crashing.

I just experienced this issue plugging in a Photon to a colleague’s windows 7 laptop. Computer runs fine until the driver installs; instantly a wild BSOD appears!
Plugging into my main PC does not cause a BSOD, so that leads me to think it is a local driver problem.

I am actually glad this topic came up. This BSOD on my Win10 Pro box Version 1709, happened to me quite often. What I did to keep this from happening was to only install the CLI tools (should I need it) on another computer and not my development PC. I cant afford the BSOD on my dev. PC to lock up like that and loose my code or corrupt my drive. I have been using Win10 Pro since it came out and develop using allot of other platforms. I never had a BSOD on win10, until I installed CLI. I have even taken the time to install a fresh copy 3 times to prove it was the CLI install that caused the issue…

Maybe now that more people are talking about it they will fix the problem

1 Like