Not able to see compile errors in desktop IDE?


I’m using desktop IDE and this is the output I get after compilation:

As you can see the compiler messages are cut off and can’t be seen properly.

Is there a way to resize this pop-up window or to see the output somewhere else?


That is a sore point right from the beginning of Desktop IDE (Particle Dev) and the Elites bring it forward regularly, but you know …

The best solution so far is to build the project with CLI. This gives you the full error output.

But with the error message as it can be seen you should have a closer look at the function signature of your own function vs. the required signature. This message just says the two function signatures don’t match.

1 Like

Hi ScruffR,

Thank you for a detailed response. That image was more an example for illustration purposes. I’ve encountered a lot of similar issues while adapting Webduino to work with Belkin Switches & Google Home Assitant (mostly I didn’t like how Webduino handles “commands” i.e. you have to provide static callbacks which then cannot access member functions and variables).

I’m a Java developer, didn’t touch C++ since 2002, so you can guess that I was struggling a bit to understand all compiler errors without having even syntax check and code auto-completion that I used to have in IntelliJ IDEA. :smiley:

I’m sorry to say but after spending a weekend playing with Particle Web and Desktop IDE, I’m quite discouraged to use those tools anymore - It’s OK if you want to turn the led on and off, but for any more complex task is too inefficient - no much benefit compared to Sublime or just any text editor.

Is there any other more modern and sophisticated C++ IDE that you would recommend for Particle development?

Shameless plug, but have you tried po-util?

It’s an alternative command line based Particle experience for Mac and Linux that makes it easy to build firmware locally without the Particle cloud and flash it over USB using DFU.

It works with the Terminal, or within Atom via handy shortcuts. It can even be used from within Vim if that’s what you’re into.

I’ve made the installation process very simple:

$ bash <(curl -sL
1 Like

Thank you!

I haven’t tried po-util, I’ll give it a go.

Generally I didn’t have time yet (maybe next weekend) to do my research. I didn’t even look is there any good C++ plugins for Atom - I assume that the guys who built Particle IDE already included what’s good and available.

1 Like