No space left on device [Fixed]

Hi Spark Team and fellow community!

First of all, thank you for this wonderful project. I have been having great fun learning and playing with Arduino for the first time. Although a little buggy at times, I trust it will be refined to perfection eventually.

I am not entirely what’s going on but hoping back onto spark.io/build today, I can’t seem to flash any code any more because the IDE says “No space left on device”:

Error: Could not compile. Please review your code.

I thought to myself, my code so far can’t be that big! And it seems like I get the same error even with a brand new project. So I assume it is a temporary issue on the cloud server?

Restarting the browser still gives me the same error.

Tim

Hi @timolol,

Hmm. I think the core has something like 128KB of flash space to run applications, and the typical user application is around ~60-70KB. Sometimes including a particular library, or including large resources can make the binary balloon way up. If you wanted to post your code, we could help identify the offender! :smiley:

Thanks,
David

Hi @Dave!

Thanks for your reply. As I mentioned, I started a brand new sketch and with only empty setup() and loop() functions and I received the same error. So I really doubt it has anything to do with the space. But is the IDE working fine on your end?

Tim

You’re right, my bad! Looks like an issue on the server, 1 sec.

Fixed! Looks like the compile server ran out of disk space and we didn’t get notified, I’ll be putting fixes in place to avoid that in the future. Looks like it was down for about ~40 minutes this morning.

Edit: Looks like it was down from “Feb 10 07:42:16” to “Feb 10 08:54:04”, so closer to 1h:12m, dang!

Thank you!
David

1 Like

Working now. Thanks for your prompt reply and action! :blush:

1 Like

Sure thing, thanks for bringing this to our attention!

wow! What was the disk space prior to this glitch and what now?

Our entire compile server runs on a single Spark Core… :wink:

Actually I think we just weren’t properly cleaning up old binaries of compiled code

3 Likes

This happened to me today. Are you out of space again? Time to bump up the compiler to two spark cores :smile:

the_user_app.cpp:78:1: fatal error: error writing to /tmp/cctVrgSQ.s: No space left on device
compilation terminated.
make: *** [the_user_app.o] Error 1

I am having the same issue now… Looks like the server needs to be cleaned up again.

Thanks guys!

Hi @abart,

Thank you, just fixed this again, working on fixing the broken monitoring script.

Thanks,
David

Hey guys, not sure if what I’m experiencing is the same problem…
I’m getting

/opt/gcc_arm/bin/../lib/gcc/arm-none-eabi/4.7.4/../../../../arm-none-eabi/bin/ld: 5a0670d792d9826fee0bb0bbf09dd3b22e5ba64427a3c6a8ebb549faa234.elf section `.text' will not fit in region `FLASH'
/opt/gcc_arm/bin/../lib/gcc/arm-none-eabi/4.7.4/../../../../arm-none-eabi/bin/ld: 5a0670d792d9826fee0bb0bbf09dd3b22e5ba64427a3c6a8ebb549faa234.elf section `._usrstack' will not fit in region `RAM'
/opt/gcc_arm/bin/../lib/gcc/arm-none-eabi/4.7.4/../../../../arm-none-eabi/bin/ld: region `RAM' overflowed by 804 bytes
/opt/gcc_arm/bin/../lib/gcc/arm-none-eabi/4.7.4/../../../../arm-none-eabi/bin/ld: region `FLASH' overflowed by 177980 bytes
/opt/gcc_arm/bin/../lib/gcc/arm-none-eabi/4.7.4/../../../../arm-none-eabi/lib/armv7-m/libg.a(lib_a-fstatr.o): In function `_fstat_r':
fstatr.c:(.text._fstat_r+0xe): undefined reference to `_fstat'
/opt/gcc_arm/bin/../lib/gcc/arm-none-eabi/4.7.4/../../../../arm-none-eabi/lib/armv7-m/libg.a(lib_a-writer.o): In function `_write_r':
writer.c:(.text._write_r+0x10): undefined reference to `_write'
/opt/gcc_arm/bin/../lib/gcc/arm-none-eabi/4.7.4/../../../../arm-none-eabi/lib/armv7-m/libg.a(lib_a-closer.o): In function `_close_r':
closer.c:(.text._close_r+0xc): undefined reference to `_close'
/opt/gcc_arm/bin/../lib/gcc/arm-none-eabi/4.7.4/../../../../arm-none-eabi/lib/armv7-m/libg.a(lib_a-isattyr.o): In function `_isatty_r':
isattyr.c:(.text._isatty_r+0xc): undefined reference to `_isatty'
/opt/gcc_arm/bin/../lib/gcc/arm-none-eabi/4.7.4/../../../../arm-none-eabi/lib/armv7-m/libg.a(lib_a-lseekr.o): In function `_lseek_r':
lseekr.c:(.text._lseek_r+0x10): undefined reference to `_lseek'
/opt/gcc_arm/bin/../lib/gcc/arm-none-eabi/4.7.4/../../../../arm-none-eabi/lib/armv7-m/libg.a(lib_a-readr.o): In function `_read_r':
readr.c:(.text._read_r+0x10): undefined reference to `_read'
collect2: error: ld returned 1 exit status
make: *** [5a0670d792d9826fee0bb0bbf09dd3b22e5ba64427a3c6a8ebb549faa234.elf] Error 1

I assume that it’s my program that is too large and would potentially overflow the space on the core? But I don’t think that’s right, as I only have a stipped down part of the MQTT Library, and a method to find the temperature from a sensor. (440 lines of code…)

I’ve not seen anything about overflow on these forums - any help would be great!

This looks like the same problem that @peekay123 was having porting a Genie library over in this thread. I think that your code is really not fitting into flash on the core. But is seems like some standard Unix filesystem commands are being linked in a weird way.

I don’t know if this ever got resolved; maybe @peekay123 can comment.

So, I had a read through the other thread, and read that his overflow could be caused by including a huge library that he didn’t need - so I removed the sstream include, which I was trying to use to convert a int to a string (albeit not successfully) and it now seems to compile fine.

2 Likes

antony, that’s a great lead for me to follow! I will look to see if that library is referenced somehow. Thanks! :smile:

1 Like

No problem @peekay123! I seem to have solved my String problem too - using the string constructor String(num, base) - now got my temps being published on an MQTT topic! Hurrah - shame it drops out after a while :confused:

1 Like

Hi Spark Team @Dave @jgoggins

I am having the same problem even with a brand new project:

Error: Could not compile. Please review your code.
No Space Left on device

Hi,

I am also getting the same fault when trying to send a file and I have tried with a blank Setup() and Loop() but same error have your servers got an issue?

Cliff.

1 Like

also having the same issue

1 Like