No option to ADD library Desktop IDE

I am working through the “documentation” for Desktop IDE and having trouble “Adding” a library to my project.

Found the library I want ok and when I click “ADD” I only get option to “Create a new Particle project”, but I don’t want another project, I want to add the library to this project.

This indicates that the active directory in your IDE is not the one containing your file.
You need to select that directory via File - Open Folder... menu.

Somehow I think I held CTRL key when clicking the “ADD” button and then was presented with small dialog box with option to Add to project or copy instead of “creating new”, The library was added now but I cannot replicate the “Add” option, if I try CTRL and click ADD , I now just get the “create” option only in this project. Does this mean the Add to project and copy option dialog only appears when the library has not already been added?

Is this documented somewhere?

I am trying to change the DS1820 library and use the Dallas one.

I cannot get the option to “Add to Library”? Yesterday I thought I held CRTL key and clicked “Use” and it brought up a window with options to Add or copy instead of create new.

What is the process to get this dialog again? Can’t find it anywhere in docs.

Here is my screen shot. The “Create a new Particle project” is only option that appears when I select “USE”

This is what I “should” be seeing

Can you post a screenshot that also shows the full file tree on the left?

Thanks ScruffR, I ready need to sort this out.I have tried all morning and cannot see how to get the option. It did appear yesterday and I don’t know what I did to get that “Add to Project” dialog to appear after clicking “USE”

I cleared out the unnecessary files from the folder and tried again but still same result

I created a new project for Photon and the library “Add” and the Serial monitor work fine.

Will try again later with Electron code. Maybe I did not open the project from file properly. Do you always need to select “Open Project Folder” before playing around with your files?

Your screenshot suggests you haven’t done what I already said yesterday

You’re still sat in ElectronCode but you should be in BlinkLed