No com port being assigned to my (photon) devices

I have been playing with my Raspberry Pis to see what is working, as compared to how a photon responded. But now that the photons updated the firmware to .60 I no longer get a COM assigned to the photons. Instead there is an entry in the device manager for ‘libusbK USB devices’. Why have I lost the COM ports. Driver Install now says that no driver is nessasary for win 10 and unistalls any old drivers. With a reboot I still have no COM ports assigned.

This might be a side effect of the newly added USB HID Mouse/Keyboard/secondary Serial feature.
I had to remove the COM drivers from my system completely (even for hidden/non-present devices).

Can you show a screenshot of DevMgr and zadig (with the devices list open)?

Here is how to show non-present devices

The photons were showing up as libusbK devices, used Zadig to change the driver to winUSB(v6.1.7600.16385) still not showing as COM. Now showing under Serial USB Devices. What is the easiest way to upload the capture? What do I have to do to backup the firmware back to .5.3?

You can just drag’n’drop the image or use the upload icon to post a screenshot.

And to downgrade, you’d need to get the system binaries from GitHub and flash the system parts in revers order

particle flash --usb system_firmware_part2.bin
particle flash --usb system_firmware_part1.bin
particle flash --usb tinker

Have you tried the Photons in Safe Mode? What are they showing up as then?

Here you go!

If you want to set the driver via zadig, you’d need to use USB Serial (CDC) and not WinUSB

But have you tried to remove the Particle drivers for non-present devices as mentioned above?

Fixed!! Knowing the right driver helps! Thanks ScruffR.


I have a Photon that after automatically updating to 6.0.0 firmware stopped being recognized via the Particle DEV Serial Monitor app. I now can only see the serial output from the Photon if I use TeraTerm Serial Monitor software.

Looks like I will need to follow this thread to make the necessary changes. I’m running Windows 10.

@RWB, that might be in connection with the newly added DTR/RTS flow control feature.
You can try activating that in DevMgr and see if that helps.

2 posts were merged into an existing topic: On the Pi the not working


I tried all the Flow control settings but I can still not connect to the Photon using the Particle DEV software Serial Monitor app.

I uninstalled the Photon and checked the box to delete the current driver software and that made no difference.

I’m restarting the machine now.


I replaced the driver via Zadig to USB Serial (CDC)

Now I can access the Photon via the Particle Dev software via serial com 10.

What is com 11 doing?

Now I have 2 devices show up in the device manager. Is this correct or did I do something wrong?

There is a driver installer that should be able to fix most of the issues:

Could you try that?

1 Like


I ran the app to uninsall previous Photon drivers and it successfully completed. I then rebooted the machine.

I tried to run the app again but it said since I’m running Windows 10 no drivers are needed.

The serial monitor app in Particle Dev will not open up the Photon anymore.

I used Zadig to change the drivers as shown below to get Particle Dev’s serial monitor to work with the Photon again. Should there be 2 listings when the Photon is plugged in as shown below?

If you are on Windows 10, Photon should have been correctly enumerated without you having to manually assign usbser. Does that not happen after the installer runs the “Uninstall previous drivers” section? (you may have to unplug/plug it back)

The second interface (Photon Control Interface) is not actually a COM port, but a WinUSB interface for vendor requests, and should also have been automatically enumerated by Win 10 with WinUSB driver. It actually even shows that in Zadig: WCID (checkmark) WINUSB.

@avtolstoy Yes you are correct, it does do all those things properly. But you can’t access the Photon via the Particle Dev Serial Monitor anymore. when you try to hit connect it just flashes real quick but does not open or show the serial output from the Photon.

Can you check that on your end.

Thanks for clarifying that Windows enumerates the device correctly.

I’m going to check what might be the problem with Dev Serial Monitor.

1 Like