New Electron, Publish doesn't log to cloud

I have a new Electron running the GPS_FEATURES example code (ASSET_TRACKER) with no changes, and nothing gets published to Logs in Console, when the batt/gps functions are called. Additionally, no “device came online” messages appear in the log. The log says “Send some events using Particle.publish() in your firmware.”

SIM Card is in (registered and not paused and has remaining data), I’ve upgraded the Electron to 0.6.1.
Device has a blue heartbeat and everything is connected correctly (battery, shield, antenna).

Device successfully connects to the cellular network, and responds to:
particle call NAME batt
for example (I’ve changed the return value of that function to verify).

Also, tried unclaiming and setting up the device again on

“My Devices” in console gives a valid last connection time.

Device is talking to, but it’s like the Publish events are going into a black hole.

Any ideas?

Is it blue blinking or cyan breathing? Blue is not cloud connected.

Double check if your device is actually listed in

Sorry, I meant it’s breathing Cyan. The device is listed and gives a valid “Last Connection” time in Console/My Devices, but doesn’t create any Log events when Publish is called. This is with the stock example code for the Asset Tracker. But the device does respond to function calls and responds to the Signal button, but the Publish within the function call that gets called doesn’t create anything in Logs.

Logs is completely empty

That’s because the publish only fires when the GPS has locked on a position!

My understanding is the publish fires when calling the “batt” function, regardless of gps lock. Although it doesn’t publish with or without GPS lock anyway.

Weird thing is, tried a simple publish this morning, and it worked, went back to the same GPS code (still not on a gps lock), and this time the code now logs when I call: particle call DeviceName batt

But I’ve also noticed something weird going on in the Console Log, which I think may have been the cause.

If I have 2 console logs open and one window is active, one not, the log only appears in the active one, the other ones says there’s no publish events. If I refresh the active one, all the entries disappear and it says there’s no publish events.

If the device has been logging for a while, then I go into the log, the log is empty. It seems the log only displays log entries since the time you’ve started watching that log page…

i.e. If I start the device, the device publishes 20 events, and I then go to Console/Log, the Log will be empty. If the device publishes another event and I have the Log window open, then I will see 1 event published. I.E. There’s no history to the log.

Is this normal behaviour?

This is dependent on your browser and not on the Particle cloud.
Particle (so far) does not buffer past events at all.