NeoMatrix Library Web IDE issue

I’m having an issue with the NeoMatrix library ever since clicking the “Migrate Libraries” button. I get the error below when I try to compile any app with the library included:

This happens with existing apps I have written (and that worked fine prior to migrating) and with new, blank apps (brand new app, include library, try to compile). This is all in the Web IDE. Any help would be appreciated.

What system firmware are you targeting and what are the versions of the libraries used?

Links to the individual libraries might help us come up with a cure.

I see the neomatrix 0.1.0 was auto-migrated to v2.0 lib format but these includes don’t play well with this.
For the time being you could go for v0.0.4 and file an issue on the github repo to correct this

#include "../Adafruit_GFX/Adafruit_GFX.h"
#include "../neopixel/neopixel.h"


#include "Adafruit_GFX.h"
#include "neopixel.h"

and add the dependecy to the file.

Thanks - I will file an issue on github.

Including v0.0.4 didn’t seem to help - I still get the same issue. Any easy way around this until the library gets updated?

You could copy-paste the library files’ contents into dedicated file tabs in your project and do the alterations yourself.
Since there are only two files to that lib it’s a piece of cake :wink:

I’ll do that. I submitted an issue for the library as well.


1 Like

Hey! just to make a note on this post. I’ve updated the library to include the changes mentioned here. The new version is 0.2.1.


1 Like