Migrating library to new library manager (Library not valid error)

I received the email about migrating your library. I tried following the directions for the desktop IDE but struggling.

I’m trying to migrate RFM69-Particle. Has it already been migrated? How can I confirm? (I see it already has a library.properties file and it appears to be available in the desktop IDE).

Selecting “manage current library” there is no “migrate this library” button. When I do try to upload the library I receive an error that “Library is not valid. main source is missing main header is missing”.

Have you got the latest version of Dev installed?

I installed it a couple of days ago when the new library manager came out. Also went into file > settings > updates and says it is up to date.
Let me double check…1.7.4 and downloaded/reinstalled right now. Still same issue.

The thing with the libarary validation is that it requires you to provide a set of .h/.cpp files that is called exactly the same way as you called the library inside the library.properties file (which we can’t see for the red message box covering that line ;-))

name=RFM69-Particle
which is exactly the same name as the .h and .cpp files.

There are two additional parts to the library, RFM69_ATC (with .h and .cpp files) and RFM69registers (only .h file). Is that causing an issue?

If it helps, here is the link to the library in the web IDE: https://build.particle.io/libs/RFM69-Particle/0.0.2/tab/RFM69-Particle.h

Another user seems to have a similar issue and Particle is looking into

Meanwhile you could use CLI.
There was an issue with the path seperators for Windows with 1.19.1 which got fixed in 1.19.2
Maybe there’s something similar at work with Dev.

Sorry you’re having issues – I’ll ping the team internally to see if we can get you some help.

I’m having the same issue with a library that definitely isn’t missing main! Also on Windows. Loving the desktop app otherwise!

Not sure what you mean?

Sorry, the error message is “main header is missing”. I was simply stating that I have experienced this same issue. Worked just fine with CLI.