Manually add a WiFi network

I want my Photon to be able to operate on either of two WiFi networks. I set up the device on network WiFiA using the IOS app. Then I took it to WiFiB and used the IOS app again to set up the Photon. I thought this would add the 2nd network to the list of possible networks to connect to. But when I took the device back to WiFiA it did not connect to the cloud. The Green LED just kept fast blinking.

What is the best way to manually set up the Photon to communicate using either WiFi network.

This definetly should work as you thought and it does with mine.

How have you set your device into Listening Mode?
Could it be that you held the SETUP button too long, till the LED flashed rapidly blue?
In this case you’d have wiped the old WiFi off.

I pressed the setup button for 3 seconds until the Photon was flashing Blue. Are you saying my prior WiFi network was erased? Isn’t this the mode the device needs to be in when running the IOS app to set it up?

I ended up using the Command Line Interface - particle setup Wifi at the two locations of the WiFi networks. They both are now programmed into the Photon and the app is displaying which network it is connected to when it initiates.

No, what I meant was, if you held SETUP down for about 10sec you might have erased the credentials.
And it should’ve worked as you did it.

@jmosk - if you have time, it would be fantastic to know if setting up via the Mobile App in both location also works. I had someone on the Particle Team raise an issue internally about it, but I couldn’t reproduce when setting up via the CLI.

In principle there should be no difference setting up via CLI or Mobile, but theory!=reality :wink: