LSM9DS1_BASIC_I2C Causes Computer To Go Insane [SOLVED]

Hi all,

Been using Electrons for a while now and this weekend I started tinkering with a photon. I had a super easy time getting my unit to work with the iphone app. Then I flashed a basic “hello world” firmware and used a serial monitor to confirm - yup it worked no problem.

Then I hooked up a 9DOF stick from Sparkfun. I flashed the example LSM9DS1_BASIC_I2C firmware available in the libraries section of the IDE. The flash was successful but then my computer went insane. The mouse was stuck to the bottom right of the screen and I could not click on anything, it also seemed to be “clicking” on its own and flashing the screen. I hard rebooted the computer and it came back up doing the same thing. I unplugged the photon from the USB and the issue stopped right away. Anyone experienced anything like this? Could it have anything to do with the USB speed of the firmware (115200) or the IC2 protocol?

There have been some topics about this already:


Thanks!! The registry edit fix in your linked post fixed the issue right up! (it was not an issue with the firmware but with Windows).