Local flash vs cloud flash build error

Local (USB) flash worked, cloud flash threw a build error looking for Time.h. I removed Time.h from my includes and cloud flash worked. There must be some difference in how the local flash and cloud flash compile/build? And why does the flash process need to build, why doesn't it just flash? The code is compiled before I try to flash. (deviceOS 5.7.0)

Welcome to the community!

In order to assess the reason for the bahiour you see, it would be important for us to know which build errors you see :wink:
"Doesn't work" isn't really helpful for guessing the possible reason.

Another helpful info to understand the reason would be to see your actual code and also where this Time.h should come from. I don't see a community library with that name.

Or do you mean the system header time.h? (which would be automatically included anyhow - if needed)

In non-Windows environments file names are case sensitive and the cloud compile is running on a non-Windows build farm.