Library not found when compiling


#1

I am trying to flash my project to my argon board and I have a few libraries (Arduino JSON, Arduino IRremote, MQTT-TLS) for the project in a “lib” folder outside of the “src” folder. When I compile it throws an error saying it cannot find the include IRremote.h which does exist in the library folder in the lib directory.

Is there a certain way I need to structure my project for the workbench to find the libraries?


#2

When you create a project with via the dedicated command
image
and install libraries via that dedicated command
image
you should get the structure as it should be

Can you also show your #include statements?


#3

Ah, I did not know about the install library command. How does the command work, what do I enter because the description of what I am suppose to type in (“Which Library?”) in visual studio code isn’t very helpful?

All I did to add the libraries was manually create folder in the project and manually copy them in.

this is how my includes look

#include "Particle.h"
#include "IRremote.h"
#include "config.h"
#include "CloudIoTCore.h"
#include "MQTT-TLS.h"
#include "ArduinoJson.h"

#4

That would be the name of the library :wink:
If you don’t know the exact name, you can use CLI (e.g. via the command “Particle: Launch CLI”) and use its search feature particle library search <yourPartialLibName>.

When installing (or manually copying) libs you need to remove the examples folder from the libraries otherwise the compile will be confused with multiple implementations for setup() and loop().


#5

Went and deleted any example folder from the libraries but I still get the same error

This is how my project is setup

44%20AM


#6

Where did you get the Arduino-IRremote library from?
I can only find these four libraries when searching irremote

IRremote 0.0.3 21752 IR Remote Control
DAIRremote 1.9.0 101
IRremoteLearn 0.0.1 55 IR Remote Control for Learner IR receivers
BeanSQ-IRremote 0.0.1 19 Particle Port v2.2.1-- Send and receive infrared signals with multiple protocols

Also I don’t know of a Arduino-JSON library with a hyphen in then name.

Are you cloud building or locally?


#7

IRremote library from here, used it on other non-particle boards but looking at the repo it might not even work

Arduino-JSON is this one I just added a hyphen in the folder name

MQTT library is

Google-Clout-IoT is

I am trying to compile/build locally through VS Code