LG5 not pairing with Argon or Xenon


#1

My LG5 is not pairing with either the Argon or Xenon. It stays on the “Pairing with your …” window. Does anyone have a solution or workaround to this problem?


Initial pairing and update fails - Argon
#2

Do you have the latest Android app?


#3

The Particle app version is 2.3.7. The LG5 is running Android 8.0.0.


#4

Seems like the LG5 phones are having issues.

Earlier reported: Mesh device setup failing with android app

I’ll see where to file this issue and hope there is a fix soon


#5

Same issue here with a Samsung S6 running 2.3.7.

Tried it with my old S3 and that works fine.


#6

More information: I updated the firmware on a Xenon to hybrid-0.8.0-rc.25-xenon.bin using the particle cli on a linux box (Ubuntu 18.04) via USB. Pairing with the LG G5 still doesn’t work.


#7

Note3 fails also downloaded latest version 5 mins ago


#8

Can we please have a workaround as this is not a great first impression after a long wait. Can you confirm this is only an issue on specific phone models or is it location/network etc. Can you give some confirmed working models? Or any other way we can start prototyping?


#9

The new rc26 firmware is likely to fix this for you. Try upgrading to rc26 on your mesh devices, and the Android app should connect just fine. Let us know how it goes!


#10

As an added note to @jensck_particle 's response, if you are having difficulty upgrading over OTA, you can refer to the upgrade methods here at [Updated 12/12] Particle Mesh Known Issues and Fixes


#11

Thanks for the info. I updated both the Argon and the Xenon with rc26(with ncp-0.0.5 for the Argon) via the cli and unfortunately the problem still persists. Neither board pairs with the Particle app on a LG G5.


#12

@dab It doesn’t seem to be a device-specific thing, since we have at least one report of the G5 working, but clearly there’s something else getting in the way.

Do you have location services disabled? Bluetooth scanning (which we need to find mesh devices) requires location services to be enabled. The next Android app build will check for this explicitly, but in the meantime you’ll have to manually enable it.


#13

also might want to check that under location/scanning that you do not have scanning toggled off. some people turn off Bluetooth scanning to save power if they do not use Bluetooth often.


#14

Progress. Turning on the G5’s location service fixed the pairing problem with the Xenon but not the Argon. The Xenon is now stuck on the “scanning for mesh networks to join”. The Argon is still stuck on pairing.


#15

Update: After several tries, I was able to pair a Argon with G5 and set up a mesh network with several Xenons. For the most part, the mesh network appears to be working properly. One Xenon in the network is flashing a red SOS signal that indicates an exit(7) error, but that’s a minor problem for another thread.

It seems the initial problem with the pairing was related to the state of the location service on the G5. I could be mistaken, but I don’t recall the documentation mentioning the importance of the location service. Particle might consider highlighting this more prominently since it may be a solution to other pairing problems, if it’s not unique to the G5.


#16

Thanks for confirming @dab.

Yes, :particle: android engineer has mentioned the point above to make it more prominent :slight_smile: