Killed my photon...how?

Hi all - very new here… please be gentle :wink:

I’m building a smart door lock… I have my photon connected to a couple LEDs and pushbuttons and that was working fine. Today I added a servo to control the deadbolt and fried my Photon. I connected to Vin, GND, and A5 (for control). The servo worked for awhile and then the Photon went lights out, never to return. I still see 5v between Vin and GND, but none of the onboard LEDs light up.

Could my servo have killed the Photon? I tried both a continuous rotation servo (FS5103R) and a Tower Pro SG-5010 servo. I found the code at http://www.instructables.com/id/Taking-Electronics-to-the-Internet-IoT-Servo/step3/Setting-up-Hardware-side/ … other than not working on “0” or “A0” as the instructable suggested, I got it running on A5 for some odd reason, until things burned out.

In a nutshell, the code does this:
Servo myServo;

myServo.attach(A5);

for(pos = 0; pos < 180; pos += 1) // goes from 0 degrees to 180 degrees
{ // in steps of 1 degree
myservo.write(pos); // tell servo to go to position in variable 'pos’
delay(15); // waits 15ms for the servo to reach the position
}

When I used the continuous rotation servo, it just ran and ran and ran…and ran…and ran, which is probably expected based on the servo type. The standard servo worked much better, but I was using that one when things died.

Any guidance on why this happened? Please help me to not kill again :wink: .

Thanks,

Bret

I have experienced issues with servos with a Photon as well. Basically, servos require more power than the VIN pin of a Photon can give out.

Servo control pins must also be on a PWM enabled pin. A5 happens to be a PWM pin.

Refer to this image for the other PWM capable pins.

A standard servo would probably be best in your situation.

Also, is your Photon broken? Does it work when just plugged into USB?

Thanks for the reply! Sorry it’s taken me so long - I’ve been traveling.

I can’t decide if I’m going to have to mount the servo off to the side and use a worm gear and worm wheel, so the continuous servo might be required. If I can mount the servo directly to the shaft of the deadbolt I can obviously use the standard servo.

The Photon does not light up at all now. I’ve only tried using the USB connector because the servos need 5v. Even though the Photon doesn’t light up, I do still see 5v between Vin and GND when I test, though the rest of the board does seem dead and my onboard code doesn’t seem to respond to my lock/unlock buttons and the LEDs that were showing the lock/unlock state do not light.

One interesting thing… when I plug the USB in, a spot immediately above the USB connector, between, and slightly below the two onboard pushbuttons (reset and setup) felt really hot - my reaction was to jerk my finger away - I don’t know if I got burned or zapped. A Laser temperature sensor showed it was only about 78F. ( The CPU was 125F by comparison.) Is that the voltage regulator? See the red oval in the picture below:

So again, how did I burn out the Photon when others have done the same thing? It sounds like I did everything right. If the servo takes more power than the Photon can provide, wouldn’t it just turn slowly or not at all? I have another Photon, but I don’t want to just wind up with 2 dead ones.

Thanks,

Bret

Yeah your Photon is definitely broken. My best recommendation would be to buy a new one.

Try using a separate battery for the Servo.

It’s not that the current can’t be supplied - the opposite is the case, it can be supplied, but the components “on the way” can’t cope with that high current and will overheat and die.
When one says “the Photon can’t supply that kind of current” (in fact the power supply does that, the Photon only passes it through) it rather means “it’s not safe to draw that kind of current” off the Photon.

Slow down there :wink:
Yes it’s broken, but maybe not beyond repair.
If you have another Photon, you can try to power the damaged one into 3V3/GND off the 3V3/GND pins of a good one (or any other reliable 3.3V source) - but only with no extra circuitry attached to any of the two.
And be quick to unplug if the damaged one doesn’t light up at all or any of them gets hot :wink:

4 Likes

Thanks, everyone. Do you think a servo with lower power requirements like this one:

might be helpful? Looks like I could power it off 3.3v (it takes 2.8-4.2). Would that be safer?

Thanks!

Bret

Yes that looks much safer. I think it would still be able to move your door lock.

You could use the other servo with its own 5v power supply, but I guess that’s too clunky for what you’re building.

Thanks very much, Nathan! :slight_smile: I appreciate the direction.

1 Like

The voltage wasn’t the issue, it was the current. Servos require quite a bit of current which you shouldn’t try to run through your Photon, to prevent it from being damaged. you can use more powerful servos than the ones you’ve used, as long as you take care to respect the power limits of the Photon. Powering the servo separately and controlling it with the Photon is the most common scenario. If you’re in doubt, don’t hesitate to ask for verification beforehand :slight_smile:

@nrobinson2000, please don’t give potentially harmful advice!
Powering anything off 3V3 (rather than Vin or even better sperarately) is not safer.
The servo is a safer bet, but powering things off 3V3 is not.
I understand, you knew that you meant the servo, but not every reader might understand it that way too.

@bschuhma, if you have blown something when connected to Vin, but your device still remained usable powered via 3V3 then this is because you only blew a cheap, easily replacable regulator on the Photon, but if you power anything that does something similar on the 3V3 pin, you are more likely do blow the controller - so DON’T, unless you KNOW it’ll be safe!
Only light weight loads should get powered off 3V3.

2 Likes

Sorry about that… :open_mouth:

1 Like