Issues using serial debugging (Mouse moving)

I had the same problem also! As soon as my program ran on the core, the mouse started doing its own thing. I had to reboot my PC for the mouse to work properly. Only when I did a factory reset did it stop. I have not tried a new sketch yet.

@Dave @zachary @zach I’m not sure which is causing the bug but it’s indeed happening

https://vine.co/v/MKX1qD1lnFp

EDIT: Sending hex over serial was causing the issue. The HEX values probably got recognized as HID commands

Serial.print(a[j], HEX);

1 Like

In terms of weird interactions / bugs, that’s pretty wild! :slight_smile: This name “Microsoft Serial Ballpoint” is magic, because searching for that shows a lot of people having this same problem with USB serial devices:

The fix for this appears to be to disable Window’s support for crazy Serial mice entirely

##Warning! This fix involves editing your registry, make a restore point first!

###I have wrecked machines by goofing up a registry edit, you should really make a restore point first.

in regedit:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SerMouse
and change the value “Start” from 3 (load on demand) to 4 (disabled)

more info here:
http://www.curioustech.net/xport.html
http://support.microsoft.com/kb/103000

Thanks!
David

11 Likes

@Dave Tested and working!

Luckily you had a fix real fast or i can’t continue to get the Camera code running! Hoping to get it working to the core ASAP for more users to try it out :slight_smile:

2 Likes

I’m glad we know what was causing this without much trouble. Nice to know we know how prevent this from happening again also. Good work guys!

1 Like

Just thinking if anyone met this issue recently…

I was trying to output the response from the GET request from google and print via Serial.

Didn’t get the terminal opened before the core starts to spill out all the data and my mouse ran all over the place.

My device manager had like 2 to 3 more mouse (ps/2 and usb virtual) appearing

Just encountered this for the first time. The registry hack fixed it for me. Thanks guys!

1 Like

I have been having this problem sending hex over USB serial.

All I did was these lines and my mouse went crazy:

void setup() {
        Serial.begin(9600);  //used with monitor
}

void loop() {
//    Serial.println("408b42A6");  //this line works

    Serial.println("408B42A6");  //this lines blows it up.

    delay(1000);
}

I will try the fix above.

I just did this fix for my windows 8.1 computer and it solved the problem. How weird printing hex makes the computer to go bonkers.

Still can’t believe that this issue still plagues Windows. :smile:

We used to have the exact same issue with Windows 2000 many many years ago with a serial device that used to send data on power up. Windows would randomly detect this as a mouse on startup. It gave us such IT headaches.

2 Likes

Dave, thanks so much for that! That was driving me nuts, and I was having a hell of a time figuring it out!

Best,
Aric

1 Like

Wow, I can’t say how much time I wasted with this bug. It was crazy because the serial monitor worked but instead of my time (reading an external RTC over I2C) I got only shit, and I thought I have wrong variable types. But only after few days I make an fully restart (my notebook usually go to standby) there was suddenly a spark core arduino mouse which jumped funny around and now I find your bug fix. :smiley:
This given me a lot of gray hairs, I promise. :older_man:

greetings from Austria!

1 Like

Ran into the (Photon) serial mouse problem too. So weird. Registry key worked like a charm.

Is there any course for Particle to address this? (Change in the drivers?)

This bug turned into a huge issue with a lab of students, where 20% of students experienced this (on both lab computers and entirely different student computers). It really is a pain to have students making registry changes as part of a lab.

1 Like

After editing registry its working for me.
Thanks :wink:

3 Likes

Me too. This thread took care of it.

1 Like

A little more than a year later this is still a problem.

I have over 20 photons, Redbears, and Cores, only one photon had this issue. I had relegated it to my do not use box about a year ago.

Pulled it out because I needed it for a project. It was doing exactly the same thing on Windows 10.

The registry edit fixed it. This thread should be given a more prominent place. Thanks @Dave

Another device back in service.

Thanks!! :smile:

2 Likes

I have marked the respective post as solution, so it will be quoted in the initial post.

3 Likes

It’s been multiple years since this was originally posted, but thank you for doing this – my student just rank into this problem. Why can’t we all just use macOS :slight_smile: :-)?

1 Like

4 years later this tip just fixed my problem with the jumping mouse pointer while trying to serial read 4 Photons at the same time :slight_smile:

2 Likes