Integrations / WebHooks not working!

Hello.

For some reason none of my integrations seem to work. I’ve tried IFTTT and also direct web hook posting to a personal server and to slack.

All get a time-out when I test it.

I am trying the simplest of posts to slack for example:

to:
https://hooks.slack.com/services/XXXX/YYYY/ZZZ

XX,YY,ZZ are my personal keys so replaced here by placeholders.

I tried sending via CURL and it works.

This is my JSON payload!

{
“text”: “TEST”
}

Also direct IFTTT direct integrations are failing. Any clues welcomed!

UPDATE:
If I add an integration to a product in the console, the product does test ok. It is only on the main /devices page in the console that does not work. BUT If I go to a product add an integration, test it… And then come back to /devices page (main) and create an integration, then it works.

Also if I add more than one integration, in the second or third, when I press test… The test that is sent to the destination end point is the first integration!. Not the integration that you are looking at

Here is my template for making slack bots with a webhook:

You would just do

Particle.publish("slack-bot", "Text to display");

To use the webhook.

Thanks for the template¡ appreciated…

My webhook works. But it has to be in products section not on devices. I thinks that the devices section needs a revision. I am having issues unless I go to products and add an integration and then go back to devices and do the same. At that point it works…

It’s kind of weird. Even if the device in question is not included as a product.

Hi @frlobo,

If I’m understanding correctly, you’re able to create webhooks in both the normal user area, and also the product area, but you’re only able to trigger the product hook?

What happens when you hit the test button for the integration on the page, or look at the history or logs on the bottom of the page? Are you sure you’re publishing a matching event, or are you seeing any hook-error / hook-response / hook-sent messages in your event stream?

Thanks,
David

1 Like

Thanks @Dave

Yes that is what happens. I can add web hooks on both with no problem.

If I go to the normal user area and create a web hook (no other web hooks created anywhere)… I am able to create it but if I test it they won’t work. (They TimeOut).

If I go to the product page and add a hook, and test it… It works!

I then go back to the normal user area, and have to create a new hook (The old one will not work). And that hook works!

I then go and delete both other unnecessary hooks (in the product page and in the user area).

Now… It is kind of intermittent. My two cents are on the SSL side of things and maybe a certificate issue or something.

This is also the case if I go to IFTTT and create an integration from their side with particle. I authorize everything but never get the hook called… Although it was previously working. Even if I de authorize and authorize IFTTT integration with Particle.

So… Go figure :blush: Its intermittent too!

Hi @frlobo,

I’m not sure I have enough information yet to properly diagnose what’s happening. Can you target your hook against something like https://requestb.in/ instead of your server, and see if you get results there? Do you have devices claimed to the user account you’re testing with? (You cannot trigger a hook unless you own at least one device, unless it’s a product hook).

Thanks,
David

1 Like

I have plenty of devices, hooks where working ok until suddenly didn’t…

I have tried triggering Slack API and also IFTTT maker API (HTTPS)… No joy. Same results…

I am not doing this on a server of my own at all.