I'm Pretty Sure I Fried One

It’s status is: solid Red. Then hard fault SOS. Then red/yellow solid

I was running an ESC using this for quite a while no problems. It has two servo wires - ground + signal that I was connecting to A4 and GND. Then I went to hook up a higher power one the same way except it had three servo control wires (I think one is for battery monitoring for low power shutoff). My problems seemed to happen when I had to guess which wire combination to make and started randomly swapping how A4 and GND were connected to those three servo wires. The ESC was powered with 14 VDC when doing that. Never got the ESC to respond. Suddenly nothing from the Photon. Those three wires have GND, 5 VDC and 3.3 VDC on them when not connected to anything. I may have hooked one of them to Photon ground.

I also used 5 V to feed a discrete in to D0 at one point about 1/2 hour before the problems began.

I must have fried it somehow but would like to understand why before frying another. Any thoughts?

I’m going to guess the issue might be caused here. Randomly swapping wires is hardly ever a good idea, much like sticking your finger in an outlet hoping not to get shocked. It might work, it might kill you. The same appears to have been true for the photon.
In the future it’d be advisable to refer to documentation of peripherals you’re trying to hook up before poking them around.

Can you still get your device into Safe or DFU mode?

I cannot get it into safe mode. I assumed I fried it and ordered two more.

I shouldn’t have randomly swapped wires. I accept the responsibility and deserve the comment. I did this because the ESC documentation didn’t help - no color coding or other. It does say that he added wire seems like a sense wire so with the low power servo wires I believed swapping was ok. I still do. Meanwhile directly on the Photon I have read that applying 5 V to D0 might be a problem, too, and that is something I did about 15 minutes before the problem.

I want to know that connecting a new Photon won’t have the same result. It seems that I can match the new ESC servo to old ESC connections by comparing the quiescent voltages on the ESC servo wires without anything attached as impedance. I conclude that certain two of the three are the proper servo wires for the TTL signal. And I’ll make sure to attach 3.3 V to D0. Any other precautions? Any idea how I might have fried a Photon by applying the wrong low power servo wires to A4 or ground? Or is 5V on D0 a killer?

I’ll be rolling the dice on Friday if I don’t hear back so hope for my luck.

1 Like

New Photon fine (as long as I don’t connect 5v source (from battery eliminator wire) to other Photon pins.) It says in several places that the Photon does not tolerate improper voltages.