I2c sensor works with Argon, but not with Photon

Hi,

I have a generic apds-9660 sensor which is working perfectly with an Argon but refuses to work with a Photon. I’ve tried adding 4.7K pullup resistors which aren’t required on the Argon. Double checked cabling and even switched SDA and SCL for poops and giggles. Both the Spark and Adafruit libraries error at init and begin respectively. I’ve tried firmware 1.5 and 1.44 on the Photon.

I’m unsure what to try next? I’ve seen there’s a history of issues with i2c on the Photon but they appear to have been resolved with 0.44.

Thanks for any pointers!
Kev

Exactly which library did you use with which device OS on which device?

Is this the only I2C device you are using with the Photon or Argon?

The pull-ups are to 3v3 with both Photon and Argon, are you sure that there aren’t pull-up resistors always on the board you are using?

I think that I have implemented this device on a Photon in the past but I can’t put my hand on the application. For the record I have never had issues with I2C on the Photon but started with 0.5.X.

Thanks. It appears I have a faulty D1 on the photon. After swapping it out with another Photon I have no further issues.