I got 15 photons for the school project but 3of them are not working

I am teaching at Kaywon University in Korea. I am teaching IOT projects. Unfortunately, There are few Photons not working properly. Three of them are having different problems.

2 of them are having a verification problems at the last moment of setup with phone. And the other one is ok during the setup part but but green light is blinking fast. Also I worked with spark core app once, but after that it’s not working.

Anyway, I am happy to work with Photons, but so far, 20% of defects are little to much. So let me know what to do with it. THank you

@tb6009, do you have the CLI setup? We can try to get it working using that :slight_smile:

I need some more details. I am working with MAC environment. I am not sure how to do it. I am pretty new to the terminal envirnmoets.
So far, one of them is kind a working for the setup, but after I open the IDE on the browser, the program is not compiling. Error messege is keep coming out. I mean Mobile set up is working, but code on computer is not compiling. So let me know what to do with it.

This could actually be due to your network running out of free DHCP IP addresses and not necessarily a Photons fault.
Make sure to set your router to always have some spare IPs free.

Sometimes the app reports a problem, but it actually worked after all. Just depower the devices and check if you can see all your devices in Particle Build.
If so, just repower them and see.
If not, try to claim them manually (e.g. with [CLI][1] or via a serial monitor).

Show your code, we might see the problem.
Error messages are welcome too.
[1]: https://docs.particle.io/guide/tools-and-features/cli/

Thanks for the suggestions.

I tried 2 things in 2-problemed-photons.

Photon#1

  1. I tried CLI mode, but code is not uploading.
  2. Connecting device to wifi is Hardly working, but after that There are Error Message on Web IDE while I compile the program which are working OK in other photons. I guess that setting up part is ok, but Some what Photon is not communicating with server. I mean my photon has some problem of wifi communication

Photon #2

  1. CLI mode is working in a way, but after wifi setup green light is flashing fast. I mean same thing happens over and over again. Wifi is not connecting.

If my problems are hardware based problem what should I do?

Without an error output to look at, there’s very little we can say or do.

1 Like

How did you try it? Does it work that way on a “good” Photon?
Make sure to have the most recent version of CLI installed and post the output of CLI when trying.
Perform a system update on the Photons via USB.

Then you might have to check what target firmware you’ve got set for this device. If all devices are set the same, it can’t be that compile fails depending on the target device, since the compiler is unaware of the physical hardware and does not need contact to the device during compilation/build. Only the OTA flashing after build needs to have contact (naturally).

You also seem to have ignored that your network might contribute to the problem

  • Depower all Photons.
  • Wait for some minutes for all handed out IPs to be released by the router(s)
  • Repower only the misbehaving one
  • Wipe the WiFi credentials from the device (hold SETUP 10+ sec till it starts rapid flashing blue)
  • Reenter credentials via particle serial wifi (device needs to be plugged into the computer’s USB ;-))
  • If it doesn’t restart automatocally, hit RESET