[Howto] Setup photon if docs step fail


You’re right about the particle serial wifi part of being able to setup without Wifi, and then going to the online build ide to claim the device.

As for the DFU update, our firmware team put out an update yesterday/today, but it only updates the firmware binaries if the application firmware you are trying to use actually needs it.

I’ll keep posting to keep you updated!

Thanks for your response, @corey. As an update, I was able to try another network (WAP2 with a password) today. Worked fine. Breathing cyan just like it should and shows up on the dashboard when claimed.

So I eagerly await the WEP / hex password fix! Any expected date?


1 Like


Once we figure things out with Broadcom and some other people we’re working with on it.

I’m not sure on a definite date in place yet.


great work kennethlimcp!
Helped me a lot getting my photons up and running.

Particle team however: why are these procedures not mentioned anywhere in the docs? In particular in the getting started via USB section?
I know a few people who struggled just like me and kennethlimcp’s instructions in a prominent place in the docs would have saved us all some time…

@corey, is there a way to force the firmware update? We all know (well maybe not everyone, just those who have tried to use it) that the I2C is broken on the Photon. At this point I am desperate for working I2C as my projects depend on it. I have multiple Photons, Sparkfun Photon Weather Shields as well as numerous I2C breakout boards. None of these work more than a couple of data pulls before the data becomes corrupt.

A fix is currently being worked on and will be tested shortly. If that works, your best bet is to compile locally using that branch. You don’t really have to know how local compile works, as long as you can follow some relatively easy steps. It’s not a scary as it sounds.
That said, there currently isn’t yet an approves I2C fix, so forcing an update wouldn’t make much of a difference. Even if so, you’d probably have to compile your user firmware to the new version as well, for which you’d have to compile locally even if the you’d updated the system firmware. Unless the Cloud compiler is updated, updating your system firmware won’t make much of a difference in this regard I’m afraid.


Right, I have been hearing about a fix in the works for a month now. I first reported the issue to SparkFun and the author of the Guide for the SparkFun Photon Shield-it was a surprise to him as this worked at some point in development and then it became broken in a firmware release. It is unfortunate that it is taking so long while partners are selling Photon shields and breakout boards that basically don’t work. There is not a lot of visibility on the issue which is unfortunate. There were promises of a firmware update by Zach in his interview (eta last week). The more people that buy this hardware and run into problems the less likely they will support the Photon platform. The lack of more formal communication and expectation setting by Particle and SparkFun is really unacceptable. Continuing to advertise and sell broken hardware (e.g. SparkFun Photon Weather Shield), implying that it works is not good for customer relations.

what exactly do you mean “force the firmware update?”
-which FW version are you referring to?


Thanks Moors7, guess I need to wait until they solve the I2C bugs.

Hi @wmjenk,

Sorry that you’re continuing to encounter this issue and that the I2C bug hasn’t yet been resolved. Our firmware team has their full energy on fixing this bug and a couple others that are plaguing us so that we can release a new version soon. That said, it’s a tricky bug that is definitely taking much longer than expected to resolve. We are also in touch with SparkFun behind the scenes, and definitely don’t blame them for this one - this is a firmware issue and is our fault, not theirs. There is nothing wrong with their hardware (as far as I’m aware), and we are working hard to fix the software bug that’s driving this.


I have just “tried” connecting my two photon’s from my workplace. That is: I work in a VERY remote area, with only 3G mobile internet available. I have two mobile phones, so I just set one in “hotspot” mode, but the little photon’s refused to connect via the android app on my Galaxy S4, after factory resetting from my home wifi, they were just flashing blue. And I tried again (many times)

So, I fired up my trusty laptop, opened up PUTTY.EXE. Entered serial mode, 9600, 8, none, 1, xon/xoff, com10.
i = gave me the device id
w = asked for my SSID, so I put it in “NOKIA LUMINA 920”, option 3 for WPA2, and the password when asked.

The little buggers still wouldn’t connect!

After a lot more rebooting and swearing, i renamed my phone hotspot to “NOKIA920” and the little tackers can now be found. So, if you cannot connect, maybe try removing any spaces within your SSID.

Now, time to play with some code!


Just for another datapoint, I have spaces in my SSID “beer palace” and that’s working. I’ll investigate with the same SSID just to rule out any length issues.

I’m a newbie trying to get my photon to work. This seemed to be the correct forum (“Setup photon if docs fail”) My issue: photon is powered and LED blinking BLUE. iPhone wifi is on and detects
the photon (“PHOTON-N4JQ”) - Open the Photon app on my iPhone, select "Setup a Photon…"
get the prompts to “plug Photon in…”, “verify LED is BLUE and blinking…” (It is), “Make sure
iOS device is conntected…” (It is) – Clicking “READY”, there is a delay of about a minute and I get a message “Could not communicate with Spark cloud. … confirm internet connection and
retry” - What am I missing or doing wrong?

Hello Corey, had issues posted in another forum and just found your comment on WEP long hex passwords being maybe an issue? Particle app cannot setup Photon

Just so happens that I am also trying to use the longer type password with WEP, do you think that might be the issue with my reported connection issues in other forum?



1 Like

WEP long password appeared to be the problem on this end, switched to WPA and app use setting up Photon went well utilizing IOS app!

1 Like

After many various attempts to get the app to find the device, I uninstalled and reinstalled the app on my Samsung phone and the app works now. Maybe an updated app from the one I installed a couple of weeks ago?

I followed the instructions (could not get particle cli to install on my Mac but the serial option worked). I have a flashing cyan light and no devices in Particle Build. Where do I go from here?

Wait, flashing cyan or ‘breathing’ cyan? If it’s flashing, could it be that there are blips of other colors in there, orange in particular?

I’d call it flashing. Brief spurts of mixed colors initially then just flashing cyan.