How to see the firmware version and how to update it to most current version

I guess not. There might be some 0.4.5 version bump between the release and production update which might have caused that.

Issue with 0.4.5 seems to be resolved.

Hey what’s the problem of the 0.4.5 ? the RGB LED mirroring function still not work?

cant do a dfu update, it doesnt run under windows 10.

I can assure you that it does work on windows 10, since that’s what I’ve been using for weeks now. What exactly “doesn’t work”? That description is a bit vague for debugging purposes…
If you’ve only recently installed node.js, try making sure your version is max 0.12.7, since newer ones (which have only recently been released), have some breaking changes.

To elaborate on the DFU proble, have tried running it as admin, as normal user, both the standard DFU and the static one, they open for a fraction of a second and then close. no idea what version of node.js i have.

What have you tried running? Have you got the particle-CLI installed properly?
If you type node -v in the command line, it should show you your node.js version.

Well this is response.
C:\WINDOWS\system32>node -v
v0.12.7
cli worked fine till it updated to the latest firmware. now cant flash anything to my photon.

That should be fine then. Could you try npm update -g particle-cli?

did that yesterday. no change.

following is output of that command

C:\WINDOWS\system32>npm update -g particle-cli

serialport@1.7.4 install C:\Users\Mulvaney\AppData\Roaming\npm\node_modules\particle-cli\node_modules\serialport
node-pre-gyp install --fallback-to-build

[serialport] Success: “C:\Users\Mulvaney\AppData\Roaming\npm\node_modules\particle-cli\node_modules\serialport\build\serialport\v1.7.4\Release\node-v14-win32-ia32\serialport.node” is installed via remote
C:\Users\Mulvaney\AppData\Roaming\npm\particle -> C:\Users\Mulvaney\AppData\Roaming\npm\node_modules\particle-cli\bin\particle.js
particle-cli@1.8.3 C:\Users\Mulvaney\AppData\Roaming\npm\node_modules\particle-cli
├── fast-luhn@1.0.2
├── xtend@4.0.0
├── cli-spinner@0.2.1
├── chalk@1.1.1 (escape-string-regexp@1.0.3, supports-color@2.0.0, ansi-styles@2.1.0, has-ansi@2.0.0, strip-ansi@3.0.0)
├── when@3.7.3
├── cli-table@0.3.1 (colors@1.0.3)
├── glob@4.5.3 (inherits@2.0.1, once@1.3.2, inflight@1.0.4, minimatch@2.0.10)
├── node-wifiscanner2@1.1.0 (os-locale@1.4.0)
├── hogan.js@2.0.0
├── request@2.61.0 (forever-agent@0.6.1, aws-sign2@0.5.0, stringstream@0.0.4, oauth-sign@0.8.0, caseless@0.11.0, tunnel-agent@0.4.1, isstream@0.1.2, json-stringify-safe@5.0.1, extend@3.0.0, node-uuid@1.4.3, qs@4.0.0, combined-stream@1.0.5, mime-types@2.1.6, form-data@1.0.0-rc3, http-signature@0.11.0, tough-cookie@2.0.0, hawk@3.1.0, bl@1.0.0, har-validator@1.8.0)
├── lodash@3.10.1
├── moment@2.10.6
├── softap-setup@1.1.4 (nconf@0.7.2, node-rsa@0.2.25)
├── inquirer@0.8.5 (figures@1.3.5, ansi-regex@1.1.1, cli-width@1.0.1, through@2.3.8, readline2@0.1.1, rx@2.5.3)
└── serialport@1.7.4 (bindings@1.2.1, sf@0.1.7, async@0.9.0, nan@1.8.4, debug@2.2.0, optimist@0.6.1)

C:\WINDOWS\system32>

Hmm, try npm install -g serialport first?

output.

C:\WINDOWS\system32>npm install -g serialport
C:\Users\Mulvaney\AppData\Roaming\npm\serialportterm -> C:\Users\Mulvaney\AppData\Roaming\npm\node_modules\serialport\bin\serialportTerminal.js
C:\Users\Mulvaney\AppData\Roaming\npm\serialportlist -> C:\Users\Mulvaney\AppData\Roaming\npm\node_modules\serialport\bin\serialportList.js

serialport@1.7.4 install C:\Users\Mulvaney\AppData\Roaming\npm\node_modules\serialport
node-pre-gyp install --fallback-to-build

[serialport] Success: “C:\Users\Mulvaney\AppData\Roaming\npm\node_modules\serialport\build\serialport\v1.7.4\Release\node-v14-win32-ia32\serialport.node” is installed via remote
serialport@1.7.4 C:\Users\Mulvaney\AppData\Roaming\npm\node_modules\serialport
├── bindings@1.2.1
├── sf@0.1.7
├── async@0.9.0
├── nan@1.8.4
├── debug@2.2.0 (ms@0.7.1)
└── optimist@0.6.1 (wordwrap@0.0.3, minimist@0.0.10)

C:\WINDOWS\system32>

So, apparently, that worked. Now, with your Photon in DFU mode, could you try particle update?

dont have my photon available at the moment, also dont have any code downloaded to install

C:\WINDOWS\system32>particle update
{ [Error: Command failed: C:\WINDOWS\system32\cmd.exe /s /c “dfu-util -l”
‘dfu-util’ is not recognized as an internal or external command,
operable program or batch file.
]
killed: false,
code: 1,
signal: null,
cmd: ‘C:\WINDOWS\system32\cmd.exe /s /c “dfu-util -l”’ }
!!! There was an error trying execute DFU utilities.

!!! For help with installing DFU Utilities, please see:
http://support.particle.io/hc/en-us/articles/203265730-Installing-the-Particle-CLI

!!! You may also find our community forums helpful:
https://community.particle.io/

Error code: 1

C:\WINDOWS\system32>

Alright, you haven’t got DFU-util installed properly, that is, it’s not in your path. Do do so, check out this tutorial (the last step):


Using this (AWESOME!) toolchain installer should also work (you can select what you want to install, CLI included):

Fixed it just before your message…lol
Just added to the path.

C:\Users\Mulvaney\Downloads\dfu-util-0.8-binaries\win32-mingw32>particle update

Your device is ready for a system update.
This process should take about 30 seconds. Here goes!

! System firmware update successfully completed!

Your device should now restart automatically.
You may need to re-flash your application to the device.

C:\Users\Mulvaney\Downloads\dfu-util-0.8-binaries\win32-mingw32>

1 Like

From CLI use particle serial identify
It will give you device id and firmware version.