How to see the firmware version and how to update it to most current version

hi guys:
I wonder how to check the firmware version. Is there any way to do it?

@mikelo The most available way is, on the web ide, select devices and click the arrow">" beside the device you want to look at, this shows the device information, your device id no and the firmware version.

it looks like this.

Place the device in Listening mode and use a serial terminal to send v for a firmware version check

to update

npm install -g particle-cli
# put device in DFU mode
particle update

what do you mean “to connect to the device press ‘v’” ? do I have to put it in dfu mode? and what kind of command I should type in? I was in dfu mode and in command line on Mac OSX. There nothing happen like what you mentioned in the post, after I press v or s.

Setup mode = listening mode (blinking blue)


I press v or s, it says command not found.

Is your device connected and in listening mode?
And where do you press that command?

in terminal of Mac OSX. I type in “screen”. and then it turn the thing into bash, then I’ve tried s or v. The responses are command not found.

Could you try it with coolterm?

ok, got it, thank you. another question is. how to update it to 0.4.5? I did particle update, but nothing was changes.

As far as I’m aware 0.4.5 is not yet released publicly. If you want to use that right now, you’ll have to compile locally.

yes, that’s what I am saying. if I want to compile it locally. what should I do?
particle update seem won’t work.

We just released 045, but you can compile it locally by moving your clone of the git repo to the right branch:

#then run something like
cd firmware
git fetch --all
git checkout release/v0.4.5
git pull


@mikelo update your CLI using npm update -g particle-cli and it will contain 0.4.5 for particle update. I just did that :smile:

1 Like

@dave Something wrong with 0.4.5 Nothing will load onto any of my Photons. This simple program works on 0.4.4 but not on 0.4.5 On 0.4.5, the Photon goes to breathing red.

void setup() {

void loop() {


// =============================================================
void blink(int pin, int times) {
    pinMode(pin, OUTPUT);

    for (int i=0;i<times;i++){

Flashing other programs give similar results in 0.4.5

Mine also is doing the same thing, updated to 0.4.5 over wifi and since update no programs will flash and when connected to wifi breathes magenta.

@steelydev @tezza i just tried on my side. Seems ok. Give it a shot again?

Same happened to me too (for 2 of my devices). i had to upgrade the CLI and perform the update via DFU and i can now run 0.4.5 software.

Is this actually the intended behaviour that i need to upgrade the firmware via USB? i was under the impression that “normally” this happens over the air when publishing a firmware with the web IDE. The 2 of 4 Photons with this problems had the same problem with 0.4.4 though… does that mean they have some kind of “hardware defect”?

1 Like