How to install Particle Dev

I am having a very hard time getting Particle Dev to work.
Googling for Particle Dev download leads to a zip file. Unpacking and installing the installer file reults in the Particle Dev editor opening some menus, but not the toolbar that is described in the documentation. It does not show the Particle menu, in fact it does not show a menu bar at all…


I was able to define a project file pointing to my sources, but there is no Particle tool bar.
Pointed by the Particle community items to the atom.io site, looking for this in the atom.io packages I found some Particle Dev packages including a meta installer, but this results in install errors (something to do with a missing serial port?!?!)
I’ve now spent two evenings in trying installing and looking for that one description of how to install the proper version and packages, but with no success.

So, am I missing something? Am I doing something wrong? I think I am following the description which sounds very simple: download and install… but apparently not so simple.

Any help is appreciated greatly,

Regards

Ray

@suda should be able to help.

try pressing alt key

1 Like

Update:

Thanks dkryder, the alt key put up the menu bar!
Then, after some trying I was able to pin the menu bar (by default it auto-hides).
In the settings menu I found the check box to disable the auto-hiding of the menu bar
In the Package menu | Toolbar I found a way to put up the toolbar and set it to the left side.
Further following the istructions in the documentation, I was able to compile in the cloud.

Next step: upload using the cloud

Apparently, the Particle Dev package:

  • does not by default show the menu bar
  • does not by default show the toolbar
    (at least in my Particle Dev).

To help future new users of Particle Dev, may I suggest to extend the either the instructions in the documentation as to how to add the menu bar and toolbar? Even better would be to add this to the settings in the Particle Dev package.

1 Like

@raytje Particle Dev package depends on some additional packages (like the toolbar). You can try installing particle-dev-complete package.

Thanks @suda, @dkryder already helped me by hitting the alt key, which was not in the docs or in the help

Particle Dev is working fine now.