How to downgrade firmware


#1

How can I downgrade firmware?


#2

Can you narrow down the situation a bit more?

What device (Photon, Electron, etc.) and what version are you going from and to?

And over-the-air or USB?


#3

Thank you @rickkas7

Photon. Wanting to go back to 0.7.0 from 0.8.0-rc.4. Using OTA.


#4

@Jimmie, have you tried to search the forum for “downgrade”?
The essence is: “Download the system binaries and flash them in reverse order”.

But if you can I’d rather do it via USB.


#5

What ScruffR said.

Go to the release site and download:

Flash them in the reverse order using the CLI:

particle flash DEVICE_NAME_OR_ID system-part2-0.7.0-photon.bin
particle flash DEVICE_NAME_OR_ID system-part1-0.7.0-photon.bin

Note that you must flash part 2, then part 1 when downgrading.


#6

I don’t know why this happens. I would like to downgrade.
I am also using 080 RC4.

I also find it strange that it talks about downgrading OTA in the Particle Updates thread.


#7

Any possibility to also share how to downgrade the Boron Firmware from 1.1.0 back to 0.8.0-rc25 or 0.9.0?

The Particle documentation Firmware Upgrade shows only one file needed for Boron, while the electron/photon apparently need part 2 and then part 1 flashed in reverse order to perform a firmware downgrade. Does this look correct for a firmware downgrade? (particle flash --usb hybrid-0.8.0-rc.25-boron.bin)

Sadly, when I flash the old 0.8.0-rc25 firmware and then flash with tinker (particle flash --usb tinker-0.8.0-rc.25-boron.bin) in DFU mode, I get a red SOS with error code #10 Assertion LED Codes and no additional troubleshooting suggestions.

Why would I want to downgrade? I inserted a 3rd party SIM into a brand new Boron flashed with the recommended 3rd Party SIM method 3rd Party SIM , including flashing with the correct APN and then Tinker app and it worked with a nice Cyan pulse using a 3rd party SIM. :slight_smile:

I then performed a particle upgrade using (particle update) and the Boron OS upgraded to version 1.1.0 and then stayed green blinking and refuses to connect using a 3rd party SIM anymore. Now, I can’t seem to get the Boron back to firmware version 0.8.0 rc-25 to test if this is an issue with only 1.1.0 firmware. Thanks

As a side note, the SOS red led also gets triggered using the Particle embedded SIM with nice Cyan cloud connecting in OS 1.1.0 and then attempting to flash back to version 0.8.0-rc25