High School Robotics Course using the Particle.io Mesh Devices Blog


#27

Still testing connection distances with the mesh devices. Here is what the students did today. We can’t just walk the 60 m outside and expect the outside Xenon to get a connection with my Argon in the window, but we could use several Xenons at 25 m intervals inside to get the outside Xenon to have a good connection. Then once it was connected we could remove the intermediate Xenons and the connection continued.

inside-outside

On another day we managed to have a student walk much farther than the field distance (> 100 m) away from the Argon, but in that situation the Argon was outside.

I would expect much better results with more Argons and Xenons working together.

Good point @RWB. This was with the default Xenons no antennas attached.

We were then going to use another Xenon and walk away from the repeater Xenon but that person did not get too far. Even though this is outside there is a fair bit of buildings around. Will do more tests when I find more cell phone chargers to power the Xenons.


#28

This is without antennas connected to the Xenon’s right?


#29

So much rides on obstructions. The Xbee 900 products use a lower (915MHz) frequency which has much better penetration. Newer mesh products use 2.4GHz which is more susceptible to obstructions and interference from other devices in the same band. This is why WiFi meshed routers are becoming popular since WiFi signals suffer the same fate. It will be interesting to see the range with rc26 (which boosts the output by +8dBm) coupled with an external antenna.


#30

Big surprise. I just flashed some code to the Xenon which seemed to stop it from connecting to my Mesh. Was about to put it in safe mode (tap RESET while holding MODE until it flashes purple about 3 seconds) then I thought that it will not work becasue the Xenon does not have Wifi. Tried it anyway and it worked fine, was able to flash some better code and back to breathing Cyan. Weird but cool.


#31

I have said before that my Ethernet Feathwing did not work at school but was rock solid at home. Today I made some code that would show Ehternet IP information. Super excited to get home and try it and guess what… My Featherwing does not seem to work anymore at home.:disappointed:

I noticed a pre-release 0.8.0-rc.26 that I don’t have installed might be the problem,that brings up another point …

How do we find out if the cloud firmware has been updated. Found this link which is 4 years old and not relevant anymore

Or is the cloud updated at the same time as the device firmware?


#32

On another issue I found this which explains some of the issues I am seeing

Continuing the discussion from [Updated 12/10] Particle Mesh Known Issues and Fixes:


#33

What do you mean with cloud firmware?


#34

Just wondering if particle ever updates how the particle cloud deals with connections to the devices?


#35

Hey @ScruffR what about this statement in the releases

IMPORTANT: Argon NCP firmware needs to be updated to v0.0.5 after updating to 0.8.0-rc.25-mesh. The release binaries can be found here

Is that something that gets auto-installed or is that something users have to install manually on the devices. Just a bit confused.


#36

Do you mean on the devices then that would be the Device OS or if you mean on their servers then it would not be firmware but software.

With the Safe Mode Healer I’d expect it to be delivered automatically too, but doing it manually is no big deal either.
BTW, if you already had 0.8.0-rc.25 you already have the NCP 0.0.5 on your device.
The NCP update is also one of the things that get flashed via the mobile app. When you setup your Argon and the app starts uploading an update to the devices the NCP update is the smaller of the two updates.


#37

Software. Where is the github for the cloud software and the version numbers?

Reason for my question is that my featherwing worked great at home 2 days ago, not it is almost useless, just wondering if particle has changed something, since my device firmware has not changed.


#38

The corporate cloud software is not open source - I think.

But there may be other factors more likely why your ethernet is not working anymore.
Have you set the device up to detect the Ethernet FeatherWing? This is not on by default.
Are you using the Particle Ethernet FeatherWing or the Adafruit one?


#39

Thanks @ScruffR that makes sense.

This would be a great place for to tell us of the cloud version

https://status.particle.io/


#40

I thougth the Particle Ethernet Featherwing did auto detect, seemed to a few days ago. I thought that was the point of the board.

you know. on the system status page it does say that mobile customers are having maintenance done. That could somehow be the problem. I will wait a while and try again.


#41

The device that gets plugged into the FeatherWing needs to detect the board, but if it’s not told to (e.g. via the dedicated switch in the mobile app) it won’t attempt to.


#42

Good point @ScruffR I may have been using a different Xenon than the one that was originally setup using the toggle on the App. That other xenon seemed to switch fine between using the Ethernet Featherwing and not using it.


#43

So today I tried the same diagram at school but using Xenons with Antenna (even though with the Photon I was ripping the Antenna connector off the board. I used to just pull the connector straight of with a slight bend, do others use pliers, bend, pull straight off???)

Note: I have now managed to take an Antenna off a Xenon without ripping the connector of the board, Not sure why I was having troubles with the Photons.

inside-outside

It seemed like things were about 10 meters better but with repeat attempts they were not stable. So it looked like the Antenna has no improvement to the Xenons. On digging deeper it looks like the Antenna is not yet activated for the Xenons but only helps the Argon with Wifi.

By @rickkas7
I’m pretty sure the function to select the external mesh antenna is not yet implemented (as of 0.8.0-rc.25).

.

.

.

Everything I have just said in this entire blog is now out of date! Looks like version 26 is out including the Android App


#44

Have you tried rc.26? This should give you 8dBm more output power.


#45

Also, did you use @rickkas7’s code to switch to the external antenna?

STARTUP(selectExternalMeshAntenna());

#if (PLATFORM_ID == PLATFORM_ARGON)
	digitalWrite(ANTSW1, 1);
	digitalWrite(ANTSW2, 0);
#elif (PLATFORM_ID == PLATFORM_BORON)
	digitalWrite(ANTSW1, 0);
#else
	digitalWrite(ANTSW1, 0);
	digitalWrite(ANTSW2, 1);
#endif
}

#46

First thoughts version 26

It says the flash was unsuccessful! but it is actually installing the new firmware. Like always I did the Xenons before the Argon, however after 2 I got bored and flashed the Argon. Very impressive that it instlled the new firmware and kept the connection alive for 2 of my Xenons to parallel install the new firmware.

Installed the Android App, was thinking of making an entirely new mesh network, but things seem fine without it at the moment.

P.S. I have 5 mesh networks going in the console, not sure how to delete old ones.

A few Xenons had to have a full reboot unplug and plug back in.

I now always full reboot Argons.

My 1 Argon and 4 Xenons seem fine at the moment. All breathing cyan, one slow to connect. I teach teenagers, these things at the moment are very similar to teenagers.

I checked my devices and all but one successfully installed version 26. Just reinstalling it now.

However one other device seems a bit fragile, so I am going to re-flash the firmware. Because it is flashing cyan. I put it in safe mode (tap reset while holding Mode about 3s till flashing redish-purple.)

First time it did not work, second time it took the flash and restarted and seems fine.

Armed with @ScruffR reminder to use the app with the Ethernet featherwing I will try it again at school (which has never worked) reminder on the featherrwing it is hard to get the device in app mode (flashing blue), since this one is flashing green. I took it off the featherwing, held the mode button 3 s until it was flashing blue then put it back on the featherwing.

WEIRD. The Xenon using the Featherwing is asking for a new network name as if it is an Argon. I am going to exit but not sure what is going to happen. But it already asked if I wanted to join the network. Kind of like an Argon that has to make a new network.