Has there been some firmware update that broke my code? [SOLVED]

I had a rather tight squeeze (only a few byte of RAM left) project on my Core that did still run (built with CLI and Particle Dev) a few hours ago.
Now after some streamlining attempts, it didn’t run anymore, so I went back step by step, till I got frustrated and tried the original again, but it’s now broken too :tired_face: :confounded:

Now immediately after bootup the Core gives me an SOS hard fault

Even after freeing some more space that would be required to run, it’s not comming back :weary:

Any ideas @Dave, @mdma or someone else?

Hi! Did you try the full firmware upgrade? I do that on Cores whenever they don’t want to play nicely. Then maybe try reflashing your firmware and see what happens.

1 Like

Hey @ScruffR!

There have been no changes to the core firmware since the 0.3.4 release, although the compile server has been recently upgraded - the upgrade provides the features needed to build photon firmware and shouldn’t have any impact on Core builds.

One thing to watch out for is global object instances, since these are initialized in arbitrary order, and can cause bugs where previously there were none! (I had the same experience with a SOS in flashee when built in the cloud, but that built fine locally.)

Can you revert to the stage at which it was working and try that again, to confirm if it’s a code change or an environment change that’s causing the SOS?


@christine, thanks for the hint, but I’ve already done that.

@mdma, I guess your suspission about the global object constructor issue was correct and did bite me too.
I’ve tried all sorts of things even changes that would break the code even more, but all out of a sudden the SOS was gone after I started to rearrange stuff and add some arbitrary delays in setup().

That is most obscure :stuck_out_tongue_closed_eyes:

1 Like