GPU process isn't usable. Goodbye

I’m attempting to install the Particle Workbench in an Ubuntu 22.04 VM and seeing a core dump. Is there a work around available for this problem?

(e3000) network@ubuntu:~/Downloads$ ./ParticleWorkbenchInstaller.AppImage
[3047:1018/084414.233042:FATAL:gpu_data_manager_impl_private.cc(439)] GPU process isn’t usable. Goodbye.
Trace/breakpoint trap (core dumped)

I’m not sure why it’s not working for you. I’m not familiar with that error and I did not get it when I tried to reproduce it.

  • Installed Ubuntu 22.04 (desktop) amd64 using a Parallels VM on Mac OS.
  • Downloaded the ParticleWorkbenchInstall.AppImage
  • chmod +x ParticleWorkbenchInstall.AppImage
  • sudo apt-get install fuse which I got an error about when I tried to run it the first time
  • ./ParticleWorkbenchInstall.AppImage
  • Seemed to install and run normally
2 Likes

I tried again with # strace ./ParticleWorkbenchInstall.AppImage to get more information and it installed without problem! After trying it again though, it failed in the same way, so not sure what the issue might be with this VM in particular. It’s VMware running on a Windows 10 machine, Ubuntu upgraded from 20.04 to 22.04.

You are running a vm, inside a VM? It is a very unprefered vm configuration.

Simply sounds like the gpu driver vmware provides is not supported by unubtu 22.04.

Try workbench under windows.