Getting started - DFU suffix signature

I connected it to my wifi using the iOS app last night and started playing with Tinker - everything was fine. This morning I tried to flash the Blink LED example, as per the Getting Started document. When I signalled the device it flashed appropriately, but when I tried to flash the code it immediately went into this mode.

If I reset/unplug-replug the device it flashes white, then green then immediately goes into flashing cyan.

The support guide and various forum posts has suggested using the CLI to run either:

particle doctor 
particle keys doctor

Afterinstalling the CLI and DFU-utils, running particle doctor gives me the errors:


and then tell me so seek advice here.

And ideas?

(p.s. I new to this so if you can give very basic instructions I’d be very grateful!)

The “DFU suffix signature” message is only a “warning” and save to ignore.

I’d rather try to revert back to Tinker via

particle flash --usb tinker

and see whether your device starts behaving again.
You can also try Safe Mode to check whether it can connect at all.

BTW, what you describe here

is the normal startup procedure which should eventually end up breathing cyan.
Do you see any other colours during the flashing cyan?

After running the
particle doctor
and getting those error messages, (but after posting on this forum) I noticed that the Photon was in safe mode and I could see and communicate with it again from the the IDE/app.

I can signal the photon and get a response, and flashing Tinker seems to work, but after what the IDE says is a good flash I’m still in safe mode. I’ve tried flashing Tinker from the IDE, from the iOS app and using
particle flash --usb tinker
while in DFU mode. Each time the photon appears to respond - it flashes green then cyan - but then it returns to a slow blue/magenta pulsing and I can’t use the Tinker app on the app.

That sounds like your device is still runing an old Device OS.
Try particle update to update to 0.7.0 and the make sure you are also targeting that version with your application firmware.

In the devices tab of the IDE the device firmware is listed as 0.7.0 with the same target.

Runningparticle update gives the DFU suffix error, but there’s also some red text saying
"Cannot read property ‘code’ of undefined"

I’ve been trying some ideas from other forum pages but I’m still stuck in safe mode.

Two other error messages that I have found though are that if I run
particle identify
I get a “Serial timed out” error, and if I run
particle token
I get a red “Invalid token” error